Metronome - Problèmes

Suite au sujet Problème avec Metronome (XMPP)... peut-être ^^

Je rencontre un souci avec Metronome ; le seul moyen de faire repartir correctement et de décommenter les lignes suivantes dans /etc/metronome/metronome.cfg.lua

—Set up a HTTP Upload service
– Component “upload.***.eu” “http_upload”
– name = “***.eu Sharing Service”

– http_file_size_limit = 610241024
– http_file_quota = 6010241024

Cependant, Movim ne fonctionne toujours pas (il reste bloqué au niveau de la page de login) ; je n’ai jamais touché à ce fichier auparavant. Et il est arrivé que Movim fonctionne, mais uniquement en “mode dégradé”…

Et donc, que raconte yunohost service regen-conf metronome --debug

142 DEBUG loading actions map namespace ‘yunohost’
159 DEBUG extra parameter classes loaded: [‘comment’, ‘ask’, ‘password’, ‘required’, ‘pattern’]
159 DEBUG initializing base actions map parser for cli
160 DEBUG registering new callback action ‘yunohost.utils.packages.ynh_packages_version’ to [’-v’, ‘–version’]
242 DEBUG lock has been acquired
247 DEBUG loading python module yunohost.service took 0.005s
247 INFO processing action [8930.1]: yunohost.service.regen-conf with args={‘force’: False, ‘dry_run’: False, ‘with_diff’: False, ‘names’: [‘metronome’], ‘list_pending’: False}

Et ensuite ?

C’est très long ; c’est juste le listing de tous les sous-domaines. Voilà un condensé :

metadata:
args:
dry_run: False
force: False
list_pending: False
names: metronome
with_diff: False
ended_at: 2019-01-19 21:13:55.333944
error: None
operation: service_regen_conf
related_to:
- service
- metronome
started_at: 2019-01-19 21:13:53.454247
success: True
metadata_path: /var/log/yunohost/categories/operation/20190119-211353-service_regen_conf-metronome.yml
name: 20190119-211353-service_regen_conf-metronome

On ne peut pas t’aider sans le log complet …

Envoyé en message privé !

Bon ben du coup, ce que je comprends c’est que tu as un domaine upload.tondomaine.tld dans ton installation. Mais la conf metronome ajoute lui meme une sorte de domaine upload.tondomaine.tld correspondant aux fichiers envoyé en HTTP upload (la fonctionnalité de metronome) et du coup il y a un conflit entre les deux…

Ça sous-entend donc que idéalement il faudrait éviter de créer des “sous-domaines” en upload.domaine.tld soi-même :confused:

Du coup, je désinstalle Girafeau, puis je supprime le domaine upload.xxx.xx et ensuite ? Y-a-t-il une reconfiguration à faire ?

Tu peux faire ça oui …

Sinon tu peux aussi modifier la conf de metronome à la main, par exemple remplacer upload par _upload là où ça va bien … (par contre si tu modifies la conf à la main, elle ne sera plus gérée par yunohost)

OK, je viens de changer le domaine pour Girafeau.
Par contre, faut-il régénérer un truc ou bien redémarrer le serveur uniquement ?

Eventuellement tu peux faire un

yunohost service regen-conf metronome
systemctl restart metronome

mais normalement ça devrait l’avoir déjà fait tout seul

C’est bon, je viens d’exécuter les commandes. Aucune erreur, me semble-t-il…
Par contre, Movim reste toujours bloqué à la page de connexion…

Et c’est nginx qui s’y met maintenant…

● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2019-01-19 21:37:49 CET; 12s ago
Docs: man:nginx(8)
Process: 17319 ExecStop=/sbin/start-stop-daemon --quiet --stop --retry QUIT/5 --pidfile /run/nginx.pid (code=exited, status=2)
Process: 11930 ExecReload=/usr/sbin/nginx -g daemon on; master_process on; -s reload (code=exited, status=1/FAILURE)
Process: 6817 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
Process: 17436 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)
Main PID: 6819 (code=exited, status=0/SUCCESS)

C’est bon, j’ai refait partir nginx. Les fichiers de configuration de l’ancien domaine n’avaient pas été supprimés sous /etc/nginx/conf.d

Une idée pour le souci avec movim ?

Moi je resolu le problème par supprimer le fichier upload.example.com.cing.lua en /etc/metronome/conf.d

Tu parles de Movim ?

Je parle de metronome.

Metronome remarche chez moi ; c’est Movim, l’application qui ne se connecte plus ; même si je mets l’identifiant et le mot de passe, la connexion se fait indéfiniment, sans résultat !