Metronome Disable XMPP Federation

Hi! I want to disable Server to Server communication (federation) for my xmpp/metronome server.

I’ve read


    modules_disabled = { "s2s" }

to global or per-server configuration would disable federation. So I did in both /etc/metronome/metronome.cfg.lua and conf.d/domain.tld.cfg.lua (after testing lua config without issues) and restarted metronome

yunohost service restart metronome
Success! Service 'metronome' restarted

but I can still receive and send messages to external recipients

So, should I disable s2s module in another config file?
should I reboot raspi ynh server? (nginx, etc.)

I think this issue is useful if one could keep one domain isolated from external servers and just for close relatives and keep another federated for general im communication.


Added info:

  • I’ve put “converse” as tag to this topic because otherwise I could not post, no metronome or xmpp tags are allowed, but I guess it’s not a Converse related issue (is a client)

  • I’ve already searched about this topic in the forum. No results.

1 Like

Have you tried to close the respective ports in the firewall? This might help…

1 Like

no, I have not. Thank you for your suggestion.

If I close server’s ports then I will not have jabber service available outside the local network for my users. I presume.

I just want to disable communication with other xmpp server but still let us communicate when outside. Lets say this is an internal chat service for my friends that will not get spammed nor disturbed by outside connections.

After reading prosody/metronome docs I thought I could disable federation this way.

Oh ok, now I understand the usage you want. I guess all your guests are yunohost users? I mean you created them in your server? How about granting permissions to use XMPP to those only and remove permissions from the Visitors group?


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.