Mauvaise ipv4 avec dyndns

,

Bonjour à tous et pleins de bisous de libriste.

Mon serveur YunoHost

Matériel: VPS acheté en ligne chez Milkywan (je balance)
Version de YunoHost: 4.3.6.2 (stable)
J’ai accès à mon serveur : En SSH + Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Ce que je cherche à faire

Utiliser un nom de domaine nohost.me pour mon serveur yunohost.

Problème

J’accède bien au portail, mais pas mes copains. Et je sais que chez moi l’ipv6 fonctionne.

Analyse

  • Mon hébergeur m’a informé que mon ipv4 était en 45.XX…, mais quand je fais un ping du nom de domaine choisi, ou un dig, ou un ip.yunohost (depuis le vps), j’ai une adresse en 80.XX…
  • dans le fichier /etc/yunohost/dyndns/zone, J’ai bien une ligne
update add *.monURL.nohost.me. 3600 A 45.XXX..

avec la bonne ipv4

  • dydns update me donne ceci
~$ sudo yunohost dyndns update
Info: No updated needed.
  • quand je tape la mauvaise ipv4 dans le navigateur j’ai moi aussi une erreur d’accès
  • quand je tape la bonne ipv4 je tombe sur le portail admin (d’ailleurs, pourquoi pas le portail utilisateur en passant ?)

Conclusion

Je ne sais pas quoi faire pour résoudre ce problème :slightly_smiling_face:
J’imagine que je n’aurai sûrement pas eu le problème avec un domaine à moi et que c’est potentiellement la config de mon hébergeur qui embête le dns dynamique de yunohost :slight_smile:
Mais du coup, si j’ai ce problème et que d’autres peuvent l’avoir autant l’identifié et le résoudre globalement

Merci beaucoup à tous pour Yunohost et pour votre aide !

P.S.: c’est pour un projet de CHATONS cette nouvelle VM :wink:

Euh… Mon problème est résolu.
Le ping -v4 indique maintenant la bonne adresse et mon copain peut y accéder.
Je n’ai rien fait, et vous ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.