Mattermost backup restore fails

My YunoHost server

Hardware: Raspberry Pi 4 at home
YunoHost version: 4.2.8.3
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Hi there, I’ve been using Yunohost for about 6 months and love it. This is the first time I’ve run into an issue that I can’t resolve.

I tried to upgrade my Mattermost version in the web admin. The upgrade failed so the upgrade script tried to restore from backup. This also failed. So now I have no Mattermost installed.

Here is the log while trying to restore from backup: https://paste.yunohost.org/raw/verawelavi

There seems to be an issue with the mySQL user privileges?
ERROR 1227 (42000) at line 1767: Access denied; you need (at least one of) the SUPER privilege(s) for this operation

My question is: how do I get Mattermost back up and running with my backup data? Thanks in advance for any help!

Ugh that’s weird … i don’t quite understand why it would require the “SUPER” privilege … If you’re at ease with tinkering etc, could you try to open the db.sql file inside the archive, and check what line 1767 looks like ?

Oh no, this was totally my fault. I said I hadn’t added anything custom to Yunohost, but I forgot that I added a database trigger to Mattermost to set a default theme for each new user. That’s the line that was throwing an error in db.sql (creating my custom trigger). I removed the line from the ,tar and the backup restore works now. Thanks for pointing me in the right direction!