Matrix Synapse unable to join public rooms

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:


Description of my issue


I’ve installed Synapse (and Element) and it’s working well: users can create an account, talk to other people on the same server or outside my server, we can make private or public rooms within our server and join them, other people from other servers can also join our public room on our own server, BUT it is impossible for us to join public room on other servers like :frowning:

When we try it, we got the message :

Auth events could not be found

Our server passes the federation tester.

It’s frustrating and I don’t know what to do now… Can you please help me ? :smiley:



Description de mon problème


J’ai installé Synapse (et Element) et tout fonctionne bien: les utilisateurs peuvent créer un compte, communiquer entre eux au sein du même serveur, y compris avec d’autres utilisateurs sur d’autres serveurs, nous pouvons créer des salons privés ou publics dans notre serveur et les rejoindre, des utilisateurs en dehors de notre serveur peuvent également rejoindre nos salons publics sur notre propre serveur, MAIS il est impossible pour nous de rejoindre des salons publics sur d’autres serveurs comme :frowning:

Lorsque nous essayons, nous avons le message suivant :

Auth events could not be found

Notre serveur passe le test de fédération.

C’est frustrant et je ne sais pas quoi faire maintenant. Pouvez-vous svp m’aider ? :smiley:

Merci !

Can you share the Synapse server logs and the time you try to join external servers?

Willingly, but how do I do that? I’m novice :confused:

Sure. In https://yourserver.example/yunohost/admin/#/services/matrix-synapse, use the button “share with YunoPaste”.

Did you also did the parts about the DNS so other servers knows how to contact yours,
(Maybe it is ausomatically done now but maybe not)

@tituspijean Thank you! Here it is. I tried again at 22:56 today, just before getting this log.

@Mamie I didn’t do anything special about DNS except forwarding to my IP and I don’t know what you are talking about :sweat_smile:

You should read this, especially the part about federation : GitHub - YunoHost-Apps/synapse_ynh: Matrix server (synapse) package for YunoHost

1 Like

Thank you @Mamie you nailed it.

My main domain is I’ve installed synapse on the subdomain

In the post installation mail, it’s written that I should configure my DNS in this way: 3600 IN SRV 10 0 8448

But sadly, my DNS registrar don’t let me configure it like this. I only can make this: 3600 IN SRV 10 0 8448 (on the main domain)

But this config doesn’t resolve my issue. I don’t know what to do. :confused:

I finally managed to configure the DNS like this:

But this hasn’t solved the issue.

With the federation tester set to instead of just the test fails:

What else could I do? Thank you!

Despite this DNS fix, I didn’t get it working. So, I finally uninstalled Synapse and installed it again without mapping the domain (I kept instead of better looking

Now it’s working perfectly.

Thanks for the help! :slight_smile:
Best regards.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.