Matrix-synapse Killed since 3.4.2.3 migration


#1

YNH 3.4.2.3 fresh migration / RPI3 / OVH box.

Just finish to migrate YNH from 2.7.14 to 3.4.2.3. It seem to be a problem with matrix-synapse service’s. Could not start.

admin@YunoHost:~ $ service matrix-synapse --full-restart
Failed to restart matrix-synapse.service: The name org.freedesktop.PolicyKit1 was not provided by any .service files
See system logs and 'systemctl status matrix-synapse.service' for details.

And then :

admin@YunoHost:~ $ systemctl status matrix-synapse.service
● matrix-synapse.service - Synapse Matrix homeserver
   Loaded: loaded (/etc/systemd/system/matrix-synapse.service; disabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: signal) since Mon 2019-02-11 17:04:59 UTC; 2s ago
  Process: 16849 ExecStartPre=/opt/yunohost/matrix-synapse/bin/python -m synapse.app.homeserver --config-path=/etc/matrix-synapse/homeserver.yaml --config-path=/etc/matrix-synapse/conf.d/ --generate-keys (code=killed, signal=ABRT)

So it’s impossible to reach each config folders. Maybe since I’ve been log with admin rather than root? Not sure about that.

admin@YunoHost:~ $ cd /etc/matrix-synapse/conf.d/
-bash: cd: /etc/matrix-synapse/conf.d/: Permission denied

I don’t really know what I can do and where I can begin to search.

"services": {
        "glances": "running (enabled)",
        "nslcd": "running (enabled)",
        "netdata": "dead (not-found)",
        "avahi-daemon": "running (enabled)",
        "postfix": "exited (enabled)",
        "rspamd": "running (enabled)",
        "yunohost-firewall": "exited (enabled)",
        "nginx": "running (enabled)",
        "php7.0-fpm": "running (enabled)",
        "dnsmasq": "running (enabled)",
        "ssh": "running (enabled)",
        "yunohost-api": "running (enabled)",
        "mysql": "running (enabled)",
        "fail2ban": "running (enabled)",
        "dovecot": "running (enabled)",
        "redis-server": "running (enabled)",
        "metronome": "running (enabled)",
        "slapd": "running (enabled)",
        "matrix-synapse": "auto-restart (enabled)"
    },


#2

Hello,

You should try un upgrade of the synapse package. It could fix some issues about the dependances.


#3

Acidope have you solved the problem? I have similar ones now :frowning:


#4

No, Sorry. I tried to update synapse, then debian but I still had errors. We were only two active person, so after some unsuccessful search I decided to delete and reinstall synapse.


#5

Ok - and did a reinstall solved the problem?


#6

Yep, but you’ll lose all history, room and discussion. A fresh new chat.


#7

heeep - this is bad - but since I´m also still in testing mode i will go for a reinstall as well, i think. Did you update also to

`https://github.com/YunoHost-Apps/synapse_ynh/tree/testing`

??


#8

not at all :confused:


#9

so does your synapse server federat with other other matrix servers?


#10

#11

No, I use it for a totally private use. I can connect to the federated server but I do not use it. All room are totally private… important thing if wants to conquer the world quietly :slight_smile: