Matomo Update PHP Version

My YunoHost server

Hardware: Old laptop or computer
YunoHost version:
I have access to my server : direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi everyone,
I did a fresh install of YUNO and installed alle the apps I need. After a few days, the application “matomo” got an update. It’s the update: 4.6.2~ynh1 to 4.7.1~ynh1.
I tried to update, but got these error:

sudo: php8.0: command not found

I can see the dependencies of php8.0 in the log:

pkg_dependencies='php8.0-curl php8.0-gd php8.0-cli php8.0-mysql php8.0-xml php8.0-mbstring'

But somehow YUNO is not installing PHP8.0. Do I have to install it by myself? Or is there something I am missing?

Here you can find the Logfile.

Best regards from

You have to run
sudo apt install php8.0-mysql

Hey Jarod,

Thanks for your reply.
Unfortunately the sources for php8.0 are missing in YUNO host.
I can install it manually, but need to know if I should do this or if there is an official YUNO way to get php 8 in YUNO?

I did it yesterday and it worked.
The update script may be missing this check, it will certainly be fixed soon

Do you just added the standard php source to your apt source lists and did an apt install php8.0?

The bug lies in the upgrade script of Matomo, calling the apt install dependency helper here AFTER L128 which already needs to have the proper php version installed:

Working on a fix in


Hey Aleks, this is good to know. Thank you very much!
What do you think: how long could it take until the fix is ready for production?

It should be available.

Thank you! The update is working!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.