Matomo - Erreur MySQL depuis quelques temps

Mon serveur YunoHost

Matériel: PCx64
Version de YunoHost: 4.0.7.1
J’ai accès à mon serveur : En SSH | Par la webadmin | En direct avec un clavier/écran |
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Depuis la mise-à-jour vers Debian 10, j’ai toutes les heures ce courriel, qui revient sans cesse :

ERROR [2020-09-13 13:05:01] 27734 Uncaught exception: /var/www/matomo/libs/Zend/Db/Adapter/Pdo/Abstract.php(112): The mysql driver is not currently installed
The mysql driver is not currently installed
#0 /var/www/matomo/libs/Zend/Db/Adapter/Pdo/Mysql.php(109): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /var/www/matomo/core/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /var/www/matomo/core/Db/Adapter/Pdo/Mysql.php(74): Piwik\Db\Adapter\Pdo\Mysql->_connect()
#3 /var/www/matomo/core/Db/Adapter.php(51): Piwik\Db\Adapter\Pdo\Mysql->getConnection()
#4 /var/www/matomo/core/Db.php(156): Piwik\Db\Adapter::factory(‘PDO\MYSQL’, Array)
#5 /var/www/matomo/core/Db.php(55): Piwik\Db::createDatabaseObject()
#6 /var/www/matomo/plugins/SegmentEditor/Model.php(253): Piwik\Db::get()
#7 /var/www/matomo/plugins/SegmentEditor/Model.php(38): Piwik\Plugins\SegmentEditor\Model->getDb()
#8 /var/www/matomo/core/CronArchive.php(616): Piwik\Plugins\SegmentEditor\Model->getAllSegmentsAndIgnoreVisibility()
#9 /var/www/matomo/plugins/CoreConsole/Commands/CoreArchiver.php(60): Piwik\CronArchive->setSegmentsToForceFromSegmentIds(Array)
#10 /var/www/matomo/plugins/CoreConsole/Commands/CoreArchiver.php(26): Piwik\Plugins\CoreConsole\Commands\CoreArchiver::makeArchiver(‘https://piwik.m…’, Object(Symfony\Component\Console\Input\ArgvInput))
#11 /var/www/matomo/vendor/symfony/console/Symfony/Component/Console/Command/Command.php(257): Piwik\Plugins\CoreConsole\Commands\CoreArchiver->execute(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#12 /var/www/matomo/vendor/symfony/console/Symfony/Component/Console/Application.php(874): Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#13 /var/www/matomo/vendor/symfony/console/Symfony/Component/Console/Application.php(195): Symfony\Component\Console\Application->doRunCommand(Object(Piwik\Plugins\CoreConsole\Commands\CoreArchiver), Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#14 [internal function]: Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#15 /var/www/matomo/core/Console.php(140): call_user_func(Array, Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#16 /var/www/matomo/core/Access.php(644): Piwik\Console->Piwik{closure}()
#17 /var/www/matomo/core/Console.php(141): Piwik\Access::doAsSuperUser(Object(Closure))
#18 /var/www/matomo/core/Console.php(93): Piwik\Console->doRunImpl(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#19 /var/www/matomo/vendor/symfony/console/Symfony/Component/Console/Application.php(126): Piwik\Console->doRun(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#20 /var/www/matomo/console(32): Symfony\Component\Console\Application->run()
#21 {main}

[Zend_Db_Adapter_Exception]
The mysql driver is not currently installed

core:archive [–url="…"] [–force-all-websites] [–force-all-periods[="…"]] [–force-timeout-for-periods[="…"]] [–skip-idsites[="…"]] [–skip-all-segments] [–force-idsites[="…"]] [–skip-segments-today] [–force-periods[="…"]] [–force-date-last-n="…"] [–force-date-range[="…

Quid de si tu met à jour matomo ?

110701 ERROR Impossible de mettre à jour matomo : Une erreur s’est produite durant l’exécution du script de mise à niveau de l’application

https://paste.yunohost.org/raw/ikegoqiput

Zblerg, la partie pertinente semble être :

   [RuntimeException]
   The .git directory is missing from /var/www/matomo/vendor/leafo/lessphp, see https://getcomposer.org/commit-deps for more information
 
 install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...
 
 Unable to update core dependencies with Composer.

mais je connais pas du tout Composer alors je sais jamais quoi faire face à ce genre d’erreur >_>