Mastodon fails when installing

My YunoHost server

Hardware: Raspberry Pi at home (RP 3)
YunoHost version: (stable)
I have access to my server : Through SSH and through the webadmin; can get access through keyboard and screen if necessary
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No

Description of my setup

Hello :slight_smile:
My Yunohost setup is as follows:

$ ssh
$ lsblk
sda           8:0    0  1.8T  0 disk 
└─sda1        8:1    0  1.8T  0 part /mnt/hdd
mmcblk0     179:0    0 14.8G  0 disk 
├─mmcblk0p1 179:1    0  256M  0 part /boot
└─mmcblk0p2 179:2    0 14.6G  0 part /

sda is an external SDD that I have set to automatically mount on booting up, and mmcblk0 is the micro-SD card that came with my Raspberry Pi from which Yunohost boots up. It also contains the root (/) directory. I have followed the instructions here to add sda to the system so that my apps’ data in /home/ is on the sda drive instead of the mmcblk0 micro-SD card. I presume Mastodon’s data gets installed there too, both for the app and for me when I’m using it.
You’ll notice that on the SD card, I have no other partitions - no swap file, which I know Mastodon prefers to have when it runs.
My installation of Yunohost is fairly new, and I intend to use it for file storage for my family using FileBrowser (all contained in /home/ in their own folders). The SSD drive sda has 2TB available.

Description of my issue (including logs)

I have tried a few times to install Mastodon from the Yunohost app repository, via the Admin interface (Admin > Applications > search for ‘Mastodon’ > install).
Doing it this way triggers an installation process that lasts for precisely 60 minutes, then results in a 504 gateway timeout error.

I have also tried installing it using screen, as per the instructions in the readme for Yunohost’s version of Mastodon, here. Doing it this way avoids a 504 error but takes approx. 4 times longer, and results in an installation or compilation error. Logs follow.

  • The log for when I tried to install with screen is here - the error is right at the end.
  • The log showing the removal of Mastodon after the failed installation is here.

I presume that if the first method didn’t end in a 504, it would end in the same way as the second method.

I intend to install mastodon under a separate, purchased domain and configure the DNS records once it’s all set up, but I haven’t got that far yet! I am not going to install it under the same domain as my family and I use FileBrowser.

I cannot find a way around this. Can anyone shed any light?

Is it a problem that I don’t have a swap file on the micro-SD card? Will it affect installing Mastodon, the running of Mastodon once it’s installed, or both? How?

Thank you in advance for your help.

Exactly same issue here, with same setup.

Raspberry Pi at home (RP 3)

Too little RAM.

Mastodon needs at least 4GB and a RPi3 has 1GB IIRC.

You can increase the swap to 8GB to fix, but that much read/write on an SD card isnt good.

As I suspected, thank you.
I’ve since gone over to Pleroma, as my attempt at using Friendica resulted in some background activity using up all the RAM and freezing my server to the point of being unusable, and so far… so good!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.