Mastodon does not work after migration to buster

After the migration from stretch to buster in my yunohost on amd64 mastodon does not work (

In nginx error.log I see

2020/08/28 17:16:05 [error] 2883#2883: *12616 connect() failed (111: Connection refused) while connecting to upstream, client:, server:, request: "POST /inbox HTTP/1.1", upstream: "", host: ""

If I try to restart the mastodon-streaming service I get this error:

● mastodon-streaming.service - mastodon-streaming
Loaded: loaded (/etc/systemd/system/mastodon-streaming.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2020-08-28 11:40:22 CEST; 5h 38min ago
Main PID: 30491 (node)
Tasks: 18 (limit: 4483)
Memory: 42.6M
CGroup: /system.slice/mastodon-streaming.service
├─30491 /opt/node_n/n/versions/node/10/bin/node ./streaming
└─31472 /opt/node_n/n/versions/node/10.21.0/bin/node /var/www/mastodon/live/streaming

Aug 28 15:40:23 systemd[1]: /etc/systemd/system/mastodon-streaming.service:11: Invalid environment assignment, ignoring: YNH_LOAD_NODE_PATH
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.`

My mastodon install was removed after a try to update. I am on a AMD64 pc.

The log of the failed update process can be read in and

Today I tried to re-install and the install process failed because some dependencies failed as you can read in

The dependencies failed are

  • x-proxy-sqlite3 (I have 1:4.0.4+dfsg-1 version in apt repository)
  • zabbix-proxy-pgsql (same version in apt)
  • zabbix-proxy-sqlite3 (same version)
  • zabbix-server-mysql (same version)
  • zephyr-server (version 3.1.2-1+b3 and zephyr-server-krb5 3.1.2-1+b3)
  • zutils (version 1.8-3+b10)
  • zfs-test (version 0.7.12-2+deb10u2)
  • zfsutils-linux (version 0.7.12-2+deb10u2)

Can you try to manually run:

apt install libpq-dev libxml2-dev libxslt1-dev libprotobuf-dev protobuf-compiler libssl-dev libyaml-dev libreadline6-dev libncurses5-dev libffi-dev libgdbm-dev postgresql libidn11-dev libicu-dev libjemalloc-dev

Ok, it worked! Thanks again a lot!

I had some issues with libssl-dev (installed now from repository) and with libreadline6-dev, its name now is libreadline (without the ending 6).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.