Mastodon cannot backup and update

My YunoHost server

Hardware: Linode VPS
YunoHost version:
I have access to my server : Through SSH & yunohost interface
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : only a cron job running apt update and upgrade, and cleaning excess media files to not run out of space every so often.

Description of my issue

Hi! After updating yunohost to the latest version, I tried to update my mastodon install (3.3.0) to the latest version.

The upgrade process was unable to backup and threw an error. To try to understand why it didn’t backup. I tried to run a manual mastodon backup. This was the result:
(pastebin )

I have enough space for a backup, mastodon install is where yunohost put it. I am at a loss as to what is going on here. Any ideas on how to debug/fix this? Thanks in advance. :slight_smile:


2022-02-21 14:30:12,083: WARNING - Source path '/etc/cron.d/mastodon' does not exist

Somehow, the backup script can’t find /etc/cron.d/mastodon. I think create an empty file at this path should be enough to let the backup script continue.
sudo touch /etc/cron.d/mastodon


This worked. Thanks very much!

1 Like

I had similar issues with a few more files missing, I did the “touch” to create the empty files. It seems to have updated now, but oddly it seems like it isn’t federating:( For example the federated timeline is not updating. Any ideas?

disregard, it just took some time and now federation is working. Thanks for your solution!!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.