Made my main domain goto wordpress but keeps loading yunohost portal

:uk:/:us: english

Hi everyone, thank you for the help and reading this, really appreciate it. I’m at wits end because for the life of me I can’t figure this out now.

My yunohost server is a pretty standard setup on bare metal, 32gb of ram. 8TB. so I have and it was pointing or directing to lets say. Then just for a bit because I had an issue, I changed it so redirected to (nextcloud).

I fixed my problem and went in and changed to once again load

Seems fine, looks fine, no errors, don’t even know where to look. Reset DNS. All is good. Except no matter what I do, also on VPNs, etc. just loads and I honesty no longer know what to do :frowning:

How do I troubleshoot this?

During WordPress install, to this question

Should this app be exposed to anonymous visitors?

did you set to yes?

I did

I spent the whole weekend trying to figure this out, and I can’t. Any help would be grand :frowning:

Thank you for the reply already and for everyone looking. This is a noodle tickler.

now I’m thinking, maybe I can double check. is there a way to find out/fix that? in case I did

Did you create a backup beforehand ? If so, it should be possible to restore it on the previous subdomain !?

no :frowning:
and so I don’t know what to do now with all the work put into it.

I just want it to load. I don’t mind reinstalling but then all the plugins, the content, the customizations, etc… I can’t lose that. I’m sorry I’m a newb

In the admin panel, each application has a button for setting that app as the domain root.

Is that the method you are using to set this up, or something else?

This is what I did to not make it default and then to try and make it default again. I also went to Manage Groups and Permissions and confirmed that wordpress is in all_users and visitors and I used the make default button, and went into the domain section and manually set it there too after it still wasn’t working, and yet it’s still not working :frowning:

What was your method for setting up this, when it was redirecting to Nextcloud? The same way?

I wonder if it must be un-set in Nextcloud somehow first. :thinking:

correct, the exact same way

On my server, for some time, the YunoHost portal was not on the main domain. = custom webapp = yunohost portal
(I changed this since a few years).

I managed this with 2 configuration :

  1. Put the webapp as the default app on the domain (can be done in the domain interface, or via the application interface in YunoHost)
  2. Set as the default server (can be done in the domain interface of YunoHost)

I don’t understand the second part there, but I’m interested in trying this fix

Here is what I have, sorry it’s in french, but « Définir par défaut », in the blue button, means « make default »
With this action, you’ll tell YunoHost that it is there that the main portal should be.

so this just looks like a subdmain added? How does one migrate the portal/etc to it?

still no other ideas for how to look into this redirect?
any ideas for backing up everything in the site (config/content/etc) and restoring it to a new install that works?

thanks for the help everyone

I found an app that backed up my wordpress content. I uninstalled the app, reinstalled wordpress mu to the same path as above
(so example, domain.tld/wp) and my portal is still domain.tld/yunohost.

Doing this fresh it all worked. I restored through this plugin (just the db and content) and bam, same problem… Is this a wordpress config issue?

what a journey.

It’s fixed. there was a plugin that was messing it all up and i’m stupid

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.