Lychee not working out of the box

Hi guys, it’s me again. Sorry to be such a problem, but I can’t seem to get stuff to work…

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 11.2.12
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no special context
If yes, please explain:
If your request is related to an app, specify its name and version: Lychee 5.3.0~ynh2

Description of my issue

I just thought this app would work out of the box, but i loaded it and… nothing. I get a screen with nowhere to click. I don’t see how to get folders set up, the documentation looks about like maybe I should just learn how to code (it looks difficult). Has anyone successfully set this app up in a production server? how did you do it?
Thank you!

There are no “error” messages - just a screen with not much to do and no instructions on how to do anything - did I miss something in the setup?

Anyway, here’s the screen I’m presented with upon a fresh install:
Screenshot_2024-06-04_22-55-11

So now what do I do? how to display / upload photos? Do i click somewhere here or…?

Thanks for any input.

There is an arrow with an incomplete rectangle at the top left of the screen. Click on it to login.

1 Like

yes, I saw that and tried it, but it doesn’t do anything. Thanks for the response, though!

Does the browser console show anything? When you open the app and when you click on the login icon?

yes, the screenshot I shared is the browser view. There are no clickable links.

Open the browser console and check if there are any error messages.

1 Like

Ahh! I didn’t read your message! sorry! good idea! Here it is:

Interesting, this is the third app complaining about mime type these days. I really don’t know how to fix it. You can search for this type of message and see what they propose as solution.
You may disable strict checking but it is not recommended

1 Like

awesome, thanks.

MIME type ('text/html') is not executable, and strict MIME type checking is enabled. · Issue #180 · GoogleChromeLabs/sw-precache · GitHub seems to suggest an issue with caching “index.html” in the nginx server, but I’m definitely not smart enough to fix this. Maybe someone else can figure it out.