LXD yunohost installation failed


I couldn’t install
LXD for yunohost

I tried in two yunohost instances :



I managed to install it :

sudo apt update
sudo apt install snapd
sudo snap install core
sudo snap install lxd
sudo adduser admin lxd
newgrp lxd

Thanks for help.

Did you run that on bare metal or on a VPS? In case of VPS, it could be that nested virtualization needs to be enabled?

I just tried on a VPS of which I don’t know whether it is enabled or not, but I couldn’t install it with error:

More details in the log

Comparing the logs, we both have busybox to be removed, with apt complaining remove is disabled. I am not versed well enough in apt lingo to recognize whether the options override that, but it does say --no-remove in the options.

I tried in an old laptop and in VM freshly installed for testing purposes.
Manual install works.

Did the manual install throw Busybox out? And now it is installed, does Yunohost manage to install the integration?

I’m using it for installing different software in containers.
I installed it using the commands above.
I was able to use lxc and install a debian 11 and a ubuntu containers in yunohost.
It is independent from yunohost, I see no integration.

Maybe it is a work in progress from the maintainer of the package, with more integration to come.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.