Lost ip after migrate VHD from VirtualBox to Proxmox

,

My YunoHost server

WAS VirtualBox BUT MIGRATED TO

**Hardware: PROXMOX
**YunoHost version: Latest
I have access to my server : Through SSH | virtual access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

All was running OK when this yunohost VHD was “inside” VirtualBox.
I convertet to RAW and imported the disk to a VM inside Proxmox.
yunohost boots perfectly but it is not asking my DHCP server an IP address.
Is getting 10.10.10.0 instead…

I guess it has something to do with the virtual drivers that auto detected queh yunohost was installed on VirtualBox and that has changed now that the VM is being emulated in PROXMOX.

this is the output of “ip a” command WHEN WORKED OK:

this is the output of “ip a” command NOW:

So, i managed to make it work again changing the /etc/network/interfaces and replacing “enp0s3” for “ens18”
it seems that PROXMOX causes debian to recognize the nic as “ens18” instead of “enp0s3” as VirtualBox did.

Besides it may have nothing to do with YunoHost itself I find useful to register the issue because the wiki explains how to setup Proxmox on VirtualBox and it’s usefull to know how to fix if this happens when migrating to PROXMOX.

Now i have another problem which is that WireGuard doesn’t work.
When i connect from my cellphone the traffic doesn’t flow anymore…

Maybe i have to finde another instances of the NIC “enp0s3” and change it to “ens18” inside wiregard config files ?

I found it !!
Replaced “enp0s3” for “ens18” here and running again!:

This has probably nothing to do with YunoHost itself, YunoHost doesn’t really handle anything at that layer in the network stack …

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.