Lost all network adapters after installing and rebooting


I installed YunoHost on an Inovato Quadra (similar to a Raspi 3) running Armbian. The install went without a hitch. When I tried following the post install steps, I received this error message:

Error: "400"

Action: "POST" /yunohost/api/postinstall

Error message:

iptables/nftables does not seems to be working on your setup. You may be in a container or your kernel does have the proper modules loaded. Sometimes, rebooting the machine may solve the issue.

I tried rebooting as suggested, but when the computer came back up, all the network adapters are missing. Before rebooting, it had both a wired ethernet adapter and a USB wifi adapter. I cannot easily try any suggestions on the Internet regarding networking because many of these tools require installing, which I cannot do because I have no network access.

$ cat /etc/network/interfaces shows only the loopback adapter:

auto lo
iface lo net loopback

I also tried $ systemctl status networking.service and it is active.

Do you think there is a problem installing Yuno on Armbian? Is there anything you can suggest to fix or diagnose this problem?

Thanks a bunch in advance. I really like what this program can do and look forward to using it.


I am not sure, but it appears the problem may be inherent in either the hardware or Armbian. I did a complete reinstall of the OS and Yunohost, and then when I was configuring a static ip, after accidently setting one up on eth0, some reboots later, then changing the config to wlan0, after another reboot, eth0 disappeared, leaving only wlan0 appearing (using ip a).

So I guess this issue can be marked resolved, but there may be some reliability issues for anyone else setting up an inovato quadra.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.