Looking for advice: SSH rejecting all admin accounts

Aloha peeps,

My YunoHost server

Hardware: kvm arm64
YunoHost version: 11.2.4
I have access to my server : through the webadmin

Description of my issue

After the last update, it became necessary for me to ssh into my server to fix the dpkg/APT. I used the usual admin login and got Permission Denied. Then, I tried the admin account for the web min login as I thought with the update it was changed and got the same message. I tried to sort out manual issues with me being in front of the computer a.k.a. not copying the password correctly. For that I created a new account for admin (added to the admin group) and typed out the password in console with the same result. I have changed the root password in the web min security console. I still have access to the server via the hosters shell in browser emulation, in which I tried to log in via root, but this was also not fruitful.

It seems to me that I can’t ssh login with any of my legacy admin or current admin account into my server via ssh. I always get Permission Denied. Although I can log in with the same credentials in the web admin console. This was not an issue before the admin account changed to the legacy admin.

Any advice?


Aloha peeps,

Mon serveur YunoHost

Matériel: kvm arm64
Version de YunoHost: 11.2.4
J’ai accès à mon serveur : via le webadmin

Description de mon problème

Après la dernière mise à jour, il m’a été nécessaire de me connecter en ssh à mon serveur pour corriger le dpkg/APT. J’ai utilisé le login admin habituel et j’ai eu un refus de permission. Ensuite, j’ai essayé le compte administrateur pour le login web min car je pensais qu’avec la mise à jour il avait été changé et j’ai eu le même message. J’ai essayé de résoudre les problèmes manuels liés au fait que j’étais devant l’ordinateur, c’est-à-dire que je n’ai pas copié le mot de passe correctement. Pour cela, j’ai créé un nouveau compte pour admin (ajouté au groupe admin) et j’ai tapé le mot de passe dans la console avec le même résultat. J’ai changé le mot de passe root dans la console de sécurité de web min. J’ai toujours accès au serveur via le shell de l’hébergeur dans l’émulation du navigateur, dans lequel j’ai essayé de me connecter via root, mais cela n’a pas été fructueux non plus.

Il me semble que je ne peux pas me connecter en ssh avec l’un de mes anciens comptes d’administrateur ou mon compte d’administrateur actuel sur mon serveur via ssh. J’obtiens toujours Permission Denied. Bien que je puisse me connecter avec les mêmes informations d’identification dans la console d’administration Web. Ce problème ne se posait pas avant que le compte d’administrateur ne soit remplacé par l’ancien compte d’administrateur.

Un conseil ?

SSH port ?

Good question. I changed the ssh port from the default. I used the port via ‘-p’.
Ah yes I didn’t mention. I am connecting via the shell ‘ssh -p PORT username@ip’

Got access over the local hoster shell with a root password that was less than the line break. I changed the root password in the web min. I am not sure what the issue is, but now I can add a workaround. Now I can add my ssh keys. I also learned that after rebooting the server I could login again with my credentials. Although I can’t copy my ssh keys to the server. Has someone done this on a yunohost server?

1 Like

Hi Alaska,

Do you mean that there is a max length in the password input field of the admin webpage?

I did without a problem that I can remember; first with the old ‘admin’ account, after the change with a new user account that plays for admin. Maybe there is a related setting in the admin-panel?

Does ssh-copy-id give an error/hint?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.