[Long]::Backup Process?


Hi All,

Since somes weeks, my raspberry (with ynh) work perfectly good but I didn’t manage backup process until now. And I dunno

  1. what I have to save.
  2. how to restore :smiley:

What I have

  • I have a nas (mounted on /mnt/mynas) with lots of space
  • I made a copy of my sdcards NOW. meaning all is installed on it) (after compression, it’s 4 giga).
  • On ynh, I ve installed lot’s of thing but mainly, owncloud, roundcube, tiny tiny rss etc…

What I would like is if once a day I have to make a restore.

  • Burn the sdcards with the image stored.
  • Copy stuffs (file, script, etcc… dunno). from the last restore backup point (with rsync or cron job…)

Do you know what exacly I have to save … (nginx data, config,data himself, etc…) and if something wrong, burn the sdcards and copy this data is ok.

Thanks a lot

You can read https://yunohost.org/#/backup_en

Launch a “sudo yunohost backup create” command.
Do a symbolic link for /home/yunohost.backup/ on your NAS to store the backup archive on your NAS as you have many space disk avialable.
The archive who is created saved all your data (nextcloud data, mails, user data…) and configuration files that are changed when you installed/removed an apps.

Do you need more information ? Just ak :slight_smile:

Hi, I tried sudo yunohost backup create (in fact there is a parameter -o, meaning no needs to ln the directory :smiley:.

But I have the following issue.
For linux dash and letencrytpt I cand understand (the first doesn’t work, the second is just key files…)
But onwcloud… I tried to install owncloud-deps but no package are presents.
The python stuff is , I think, the -o parameter. Will check in code what’s appening.

For information, the tar.gz is created (2.4 giga byte in /mnt/MyNas/raspi_backup)…

pi@yunohost:~ $ sudo yunohost backup create -o /mnt/MyNas/raspi_backup/
Attention : L’application « linuxdash » ne sera pas sauvegardée
Attention : L’application « letsencrypt » ne sera pas sauvegardée
Attention : dpkg-query: package ‘owncloud-deps’ is not installed and no information is available
Attention : Use dpkg --info (= dpkg-deb --info) to examine archive files,
Attention : and dpkg --contents (= dpkg-deb --contents) to list their contents.
Erreur : Impossible de sauvegarder l’application « owncloud »
Traceback (most recent call last):
File “/usr/bin/yunohost”, line 212, in
password=opts.password, parser_kwargs={‘top_parser’: parser}
File “/usr/lib/python2.7/dist-packages/moulinette/init.py”, line 138, in cli
moulinette.run(args, output_as=output_as, password=password)
File “/usr/lib/python2.7/dist-packages/moulinette/interfaces/cli.py”, line 352, in run
ret = self.actionsmap.process(args, timeout=5)
File “/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py”, line 467, in process
return func(**arguments)
File “/usr/lib/moulinette/yunohost/backup.py”, line 303, in backup_create
’{:s}/{:s}.info.json’.format(archives_path, name))
OSError: [Errno 2] No such file or directory
pi@yunohost:~ $ apt-cache search owncloud-deps
pi@yunohost:~ $

Ok, I opened 2 bugs…