Locales en français sur Raspberry


#1

Bonjour,

Après une installation neuve de yunohost sur raspberry, j’ai un souci avec les locales qui ne sont pas en français :
Pourtant le ‘‘cat /etc/default/locale’’ me donne bien :

LANG=fr_FR.UTF-8

et la commande “locale” :

LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE=“en_US.UTF-8”
LC_NUMERIC=“en_US.UTF-8”
LC_TIME=“en_US.UTF-8”
LC_COLLATE=“en_US.UTF-8”
LC_MONETARY=“en_US.UTF-8”
LC_MESSAGES=“en_US.UTF-8”
LC_PAPER=“en_US.UTF-8”
LC_NAME=“en_US.UTF-8”
LC_ADDRESS=“en_US.UTF-8”
LC_TELEPHONE=“en_US.UTF-8”
LC_MEASUREMENT=“en_US.UTF-8”
LC_IDENTIFICATION=“en_US.UTF-8”
LC_ALL=en_US.UTF-8

raspi-conf ni dpkg-reconfigure locales n’y changent rien…
Un souci avec mon accès SSH ?
Sinon je peux modifier à la main /etc/locale.gen mais pas très propre ?

Merci
Fred


#2

Bonjour @FredM

Quel est ton besoin ?

Que dit dpkg-reconfigure locales ?

Je ne sais pas exactement quel partie de la locale est géré par yunohost, qu’est-ce qui te fais penser que modifier /etc/locale.gen n’est pas très propre ?


#3

Bonjour,

Le lancement de ‘locale-gen’ donne :
Generating locales (this might take a while)…
en_US.UTF-8… done
fr_FR.UTF-8… done
J’ai essayé de désactiver en_US.UTF-8 mais cela ne change rien.
Mon besoin est de franciser nano, mc…

Fred


#4

Bonjour,

J’ai retenté une install yunohost sur raspberry 3 et dès le démarrage j’ai ce message :

-bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
-bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

Ce problème est résolu avec un changement des locales dans raspi-config mais j’ai ces messages d’avertissement et les applications nano, mc et autres restent en anglais ;(( :
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = “en_US.UTF-8”,
LANG = “en_GB.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“en_GB.UTF-8”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)…
en_GB.UTF-8… done
fr_FR.UTF-8… done


#5

Bonsoir,

Peut-être faire un tour ici [FIXED] Bug: Locale is Unable to Set

ppr