[Listmonk] Newsletter and mailing list manager



Listmonk is a standalone, self-hosted, newsletter and mailing list manager. It is fast, feature-rich, and packed into a single binary. It uses a PostgreSQL (⩾ v9.4) database as its data store.

Shipped version: 2.1.0~ynh1

Demo: https://demo.listmonk.app/


Documentation and resources


Hardware: VPS bought online ( Contabo )
YunoHost version: (stable)
I have access to my server : Through SSH and browser
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

i was trying to install this app, but the installation just failed?
here’s the log.

Can you test with a simple alphanumerical password ?

it worked! how come? :sweat_smile:

Do you recall your previous faulty password? so we can try to guess what was wrong

yes, i do, should i dm you?

If it is not a password you are using somewere else…
Edit : any special characters, spaces?

anyway, it was that specific special character because i’ve tried others they worked properly.
however, the app doesn’t let me login as the admin. :sweat:

Did you set it to public or private app?

public a.k.a. exposed to anonymous visitors.

I installed the app multiple times and, every times, I can’t connect to the admin interface.
I use an alphanumerical password, to see, same error. I don’t understand what could be the problem.
Thank you for your help.

Hi, can you please refer to this issue and the posted solution: can't log in after install · Issue #2 · YunoHost-Apps/listmonk_ynh · GitHub

1 Like

Thank you @navanchauhan
I saw to the issue on GitHub, but the suggested solution does not seems to be totally functioning.
Indeed, the connection works from private navigation or accessing directly to the URL of the app (after cleaning the browser cache), but, sadly, it doesn’t work from de YNH portal by clicking on the tile.
But, it works someway, so thank you for your time.

I haven’t had the time to figure out why it hasn’t been working since I became the maintainer for the package. I do plan on solving all issues across all of my packages in the next 2-3 weeks

1 Like

For anyone browsing the thread now, everything should be working :slight_smile:

Happy holidays!

1 Like

Yep, it works for me. Thank you so much !


I have installed listmonk on my yunohost server. I would like to customise the subscription form, css files and the different email templates, but I cannot find them in /var/www/listmonk

Where are they installed by default ?

Thanks a lot

I see that there is a new update A new update v2.5.1 is available that seems really interesting since it allows to use attachments.
Would it be possible to update the app?
Thank you! :slightly_smiling_face:

the app as already been updated.

Oh right, thank you.

I’m trying to upload an image / pdf but I receive this error.

error uploading file: open uploads/Untitled-Document-1.csv: no such file or directory

is it the same for you? Thank you