Linuxdash service fails to start : systemctl didn't recognize this service ('NoSuchUnit')

Hello all!

Update: I just found out why my server crashed. My hdd is dying :frowning:
Could this still be related?

Today I’m having issues with linuxdash. The yunohost (or systemd?) service refuses to run.

My YunoHost server

Hardware: Old laptop
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no


My server crashed. (Don’t know why yet)
After a power cycle I went to see if all apps were still running properly.
All were fine but linuxdash

Linuxdash service does not exist

Linuxdash service won’t start. On the linuxdash service webpage I get

Error: failed to get information for this service, it doesn't exists for systemd

If I try to start it I get the message

Failed to get status information via dbus for service linuxdash, systemctl didn't recognize this service ('NoSuchUnit').

Apparently the systemd unit file is gone because these commands return nothing

sudo systemctl list-unit-files | grep -i dash
sudo systemctl list-unit-files | grep -i linuxdash
sudo systemctl list-unit-files | grep -i linux
ls  /usr/lib/systemd/system | grep -i dash


Removing and installing the app again does nothing. Same issue
I tried to restore the app from a backup. Still the same
When I look through the backup files, I can see that there is no ‘linuxdash.service’
Only a ‘apps/linuxdash/settings/conf/supervisor.service’

What now?

Do I need to create the service by myself? If so, how do I do that


Je parle français si vous préférez me répondre dans la langue de Moliere.
J’utilise l’anglais pour aider un maximum de personnes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.