Limit access to Yunohost to only local LAN/ Seulement access local pour mon serveur Yunohost?

,

Hello Everyone! Thank you for the amazing work you do, I love everythig about Yunohost!
(I’m sorry for my french, I’m not a native or fluent speaker by any means)

My YunoHost server

Hardware: Old laptop
YunoHost version: 3.6
I have access to my server : SSH, WebAdmin, Direct Access through keyboard/screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No.

Description of my issue

Is there a way to make my yunohost server only accessible from lan addresses (so 192.168.1.x) ? So the only way you can access any of my apps or admin is through other computers in the same house.

I did setup a “yunohost me” domain when I first set up yunohost, do I have to reinstall everything to make this work? Because that’s not a problem.

(I searched the forum and there was no solutions)

Thank you!!


Mon serveur YunoHost

(I’m sorry for my french, I’m not a native or fluent speaker by any means)

Matériel: Vieil ordinateur
Version de YunoHost: 3.6
J’ai accès à mon serveur : SSH | WebAdmin | clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

esque ç’est possible que je rendre yunohost accessible uniquement à partir des adresses IP LAN (comme 192.168.1.X)?

J’ai un domain “nohost me” que j’ai installer quand j’ai fait l’instalation du yunohost la premier fois. Si je doit reinstaller Yunohost c’est pas un problem.

Merci!!

So you want to make is inaccessible from outside, to put it otherwise ?

If you’re behind an internet router, why not remove the port forwarding configuration ?

Yes sir, I do not want it accessible from the outside, only from computers connected to my router.

Kinda of a stupid general question but is there an option in my router to do this just for the IP of my server? I set up a static local address for my server in my router so I can always access it from one ip (192.168.1.6 for example) and not have it randomly change.

EDIT: and that’s the only change I made in my router, I never forwarded ports or such for that static IP or any other settings.

Oh … then it might be that UPnP (something that magically configure port forwarding) worked for you lol … that’s something implemented in Yunohost but never really saw it working (the corresponding code is kinda weird and silently fails)

Anyway, can you try to look into your router if there’s something about port forwarding ? Or maybe try to run yunohost firewall upnp disable, but that’s a huge guess and I’m not even convinced that function would remove already configured forwarding rule … but maybe I’m too pessimist xD

Oh awesome! My router is the Huawei HG532s if anyone is looking for an easy yunohost router then! I will check for port forwarding rules and check back here in a little while.

Thank you Aleks for your help!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.