[LimeSurvey] Create complex poll

LimeSurvey for YunoHost

Integration level
Install LimeSurvey with YunoHost

This package allow you to install LimeSurvey quickly and simply on a YunoHost server.
If you don’t have YunoHost, please see here to know how to install and enjoy it.


LimeSurvey is used to create advanced poll.

Shipped version: 2.62.5

Categories: Productivity, Poll



Before to run the install YunoHost ask you an admin user, you can use it to connecte you on https://your_limesurvey_url/admin/


  • YunoHost documentation: There no other documentations, feel free to contribute.

YunoHost specific features

  • In private mode, only authorized YunoHost members can create poll, with the public mode, it’s possible to create account to people with no YunoHost account.
  • SSO and LDAP are configured.
  • Login secured by fail2ban

Multi-users support

Not supported.

Supported architectures

  • x86-64b - Build Status
  • ARMv8-A - Build Status


Additionnal informations


Developers infos

Package by: ljf

Patches author: Shnoulle

Please do your pull request to the testing branch.

To try the testing branch, please proceed like that.

sudo yunohost app install https://github.com/YunoHost-Apps/limesurvey_ynh/tree/testing --verbose
sudo yunohost app upgrade leed -u https://github.com/YunoHost-Apps/limesurvey_ynh/tree/testing --verbose
1 Like

This package is now level 7. So it is candidate to become an official apps. But before it should be reviewed and more tested…

I just check limesurvey. It seems work good.

Just a small thing :wink:
When we arrive on main page of limesurvey, we can’t do anything !
So, I know the doc explain we must add /admin to create a new poll. But it’s not really simple.
I hate this kind of software where you must add /admin or ?admin, definitively it’s not ergonomic.

Can you add a link on the main page ?

All YEP until level 7 are ok.

I review all your code. Some things:

  • Some helper need more comments, especially ynh_export. It’s not accessible for a novice user.
  • install:58 sudo yunohost app addaccess $app -u $admin. Here you remove access to all others users, it’s really what you want?
  • upgrade:22 ynh_exit_if_up_to_date. You forgot the upgrade of the other files, php and nginx. You may need to upgrade the package without upgrade the app itself.
  • upgrade:58 sudo rm -Rf $local_path. It’s better with ynh_secure_rm
  • backup:4 set-e. What’s going on if your backup fail? In which state is the backup?
  • backup:34 > ./dump.sql You mean $backup_dir/dump.sql?
  • restore:481 ynh_trap_on Same as backup, what’s going on if the restore fail?
  • restore:526/527 Why || true !? Why you shut up errors here?

Thanks ! :slight_smile:

[quote=“Maniack_Crudelis, post:6, topic:2445”]
Some helper need more comments, especially ynh_export. It’s not accessible for a novice user.
install:58 sudo yunohost app addaccess $app -u $admin. Here you remove access to all others users, it’s really what you want?[/quote]
Yes, I think it’s better to restrict access to the admin, if needed the yunoadmin or the ls admin can add access. But, I am agree it’s a point of view.

upgrade:22 ynh_exit_if_up_to_date. You forgot the upgrade of the other files, php and nginx. You may need to upgrade the package without upgrade the app itself.[/quote]
No my idea is to update version number at each new version of the package.

upgrade:58 sudo rm -Rf $local_path. It’s better with ynh_secure_rm[/quote]

I need to test it. The question is, should we make the script fail or should we try to save the most of things !

It’s the same because i am in the $backup_dir by default

I am not sure, we need to test it too.

Exact it shouldn’t be done like this.

On the apps page it says that limesurvey is rated level 0 and the last version was from 2015. That is contradictory to the information given in this thread.
Is it safe to install the app? Does it work?

Check the latest PR for the app https://github.com/YunoHost-Apps/limesurvey_ynh
Maybe @ljf can tell the present status.

The Limesurvey 3.0 should be released in some days. I think I could remake the package at this date.

1 Like

Thank you for your replies. I will probably wait until you updated the package since I’m not in a hurry.

Hi, Installation of LimeSurvey package is not working on my Yunohost instance.
I’ve tried several times with web interface and moulinette.
I’ve tried to remove the “LimeSurvey” database with PhpMyAdmin but couldn’t find any database with this name.
Here is the console log :

Warning: 2018-01-29 15:48:45 URL:https://codeload.github.com/LimeSurvey/LimeSurvey/tar.gz/2.64.5%2B170331 [73688260/73688260] -> “limesurvey2.64.5+170331.tar.gz” [1]
Warning: Corrupt source
Success! The SSOwat configuration has been generated
Error: Installation failed

Thanks for your help !

LimeSurvey package installation is crashing.
Here is my “Trace”

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/moulinette/interfaces/api.py", line 406, in process
    ret = self.actionsmap.process(arguments, timeout=30, route=_route)
  File "/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py", line 495, in process
    return func(**arguments)
  File "/usr/lib/moulinette/yunohost/app.py", line 692, in app_install
    _check_manifest_requirements(manifest, app_id)
  File "/usr/lib/moulinette/yunohost/app.py", line 1735, in _check_manifest_requirements
    m18n.g('colon', m18n.n('app_incompatible'), app=app_instance_name),
  File "/usr/lib/python2.7/dist-packages/moulinette/core.py", line 205, in n
    return self._namespaces[self._current_namespace].translate(key, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/moulinette/core.py", line 92, in translate
    return self._translations[self.locale][key].encode('utf-8').format(*args, **kwargs)
KeyError: 'app'

Is there any way to make the installation work ? Thanks !

Hm, not sure to know why the display / translation of this message is buggy (which language is your system using?) but basically it’s trying to say that this app is not compatible with your YunoHost version… (Are you up to date ?)

Nevertheless, the app really seems broken at the moment : https://dash.yunohost.org/appci/app/limesurvey … but I think @ljf is to work on it sometimes soon™ :wink:

@Limezy @lars @kanhu : Finally I have updated the package. :tada:

Call for testers

I will be happy if some people tests it. I have run package check suite test successfully, so it should be ok.

Note: like in the previous package for now the bug “Logout doesn’t log out” is still here because Limesurvey reconnect directly with the REMOTE HTTP AUTH, so you need to log out before on sso…


Does not work on my setup !
I tried the standard and the testing branch, got the same errors.
Here is where things seem to go wrong :face_with_raised_eyebrow:

+ yunohost app ssowatconf                                                                                                                       
The SSOwat configuration has been generated                                                                                                     
+ systemctl reload nginx                                                                                                                        
+ ynh_print_OFF                                                                                                                                 
+ set +x                                                                                                                                        
Warning: _common.sh: line 297: mail: command not found
Warning: _common.sh: line 297: echo: write error: Broken pipe
Warning: !!
Warning:   limesurvey's script has encountered an error. Its execution was cancelled.
Warning: !!
Executing script '/var/cache/yunohost/from_file/limesurvey_ynh-testing/scripts/remove'...

Sorry about that, it will be fixed soon™ in some coming releases.

In the meantime, you can manually install mailutils :

apt-get install mailutils
1 Like

Works perfectly, thanks!

New testing version:
Will be merge in 1 week if nobody report issues


Une nouvelle version du package (3.17.1) a été mise en ligne pour corriger le soucis de mise à jour. Les indications de progressions ont été ajouté au script d’installation.

Hey there,
So great to see a good survey tool on Yunohost :blush:
Although currently, I wasn’t able to install it. I think that I may have found a bug. Could you perhaps help me determine if I did something wrong, or if it is indeed a bug? I wrote all the details in a support post: Cannot install LimeSurvey app

Thanks a lot for your work on this!

Thanks a lot to @yalh76 for the recent upgrade of this app, it works well :smiley_cat:

1 Like