Let's Encrypt certificates not auto-renewing

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.3
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I noticed a few of my Let’s Encrypt certificates have expired (e.g. “valid for -12 days” in the webadmin), I tried running: $ sudo yunohost domain cert renew and it says: No certificate needs to be renewed.

I tried to renew one via the webadmin and it worked.

I ran diagnostics and everything comes back as “Everything okay!”, is there anything else I should look for or try to investigate/fix the issue of the certs not auto-renewing?

Following up with this, I have one domain now that says valid for -12 days, I manually renewed it, and it still says valid for -12 days, but when I view the Let’s Encrypt certificate in the browser it says it’s valid and valid until “Fri, 10 Nov 2023 17:38:39 GMT”. I think it just might be the webadmin displaying the wrong information, which makes sense why yunohost domain cert renew didn’t renew any certificates.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.