Lemmy installation issue

I’m trying to do a fresh Lemmy install and the installation is successful and the app gets installed fine but it does not start and looks like the “lemmy-ui” service is not restarting.

Here is the installation log: https://paste.yunohost.org/raw/iyiwapacag
Here is the lemmy-ui restart log: hastebin

I appreciate it if someone could help me fix this.


Any update here?
still can’t install the lemmy na d the lemmu-ui service does not start.


Hello, I can reproduce and I found a solution :

cd /var/www/lemmy/lemmy-ui/
sudo -u lemmy env PATH=/opt/node_n/n/versions/node/20/bin:/opt/node_n/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin npm rebuild --verbose sharp

Then, restart Lemmy UI (systemctl restart lemmy-ui)

Adapted from : Cannot find module '../build/Release/sharp-linux-x64.node' · Issue #3717 · lovell/sharp · GitHub

1 Like

Worked for me, thanks!

Thanks. I was able to install but a few issues:

  1. When I upload a media (image, icon, banner etc) I get the following error “SyntaxError: Unexpected token ‘R’, “Request er”… is not valid JSON” do you know how this can be fixed?

  2. The default yunohost email is not working (it works for other services on the same yunohost instance). Is there a way fix the email server or setup a custom smtp?

  3. What is the best way to upgrade to the latest stable version?

Thank you!

  1. This happens because Pict-RS (a Lemmy component which manages media uploads) is not currently integrated in the YunoHost package. Code has been written to integrate it but it’s not released yet.

  2. The YunoHost package was not configurating e-mail server

These two problems can be solved and I hope that an update will be available soon, I requested it here

  1. The YunoHost package is stuck with Lemmy version 1.18.2 as the newer versions require a newer version of PostgreSQL (a database system used by Lemmy), which is not compatible with YunoHost yet.
    Currently YunoHost has PostgreSQL 13 and Lemmy requires version 15+. We need to wait for Debian 12 (Bookworm) upgrade…

I just saw a new Lemmy update and when I tried updating I got the following error: https://paste.yunohost.org/raw/aqiwuteqol

Note, I updated my Yunohost System first.

Can you please check and fix?

Thank you,

I have pushed a quick fix, can you try it? yunohost app upgrade lemmy -u https://github.com/YunoHost-Apps/lemmy_ynh/tree/testing -F

(edit: blob → tree)

1 Like

That did not work and gives this error:
Screenshot 2024-01-05 at 8.53.12 AM

I hope you can get this fixed and release a new update soon.


that should be:

yunohost app upgrade lemmy -u https://github.com/YunoHost-Apps/lemmy_ynh/tree/testing -F

(tree instead of blob)

Thanks. that worked but with bunch of errors and warning and the website is not accessible anymore.
lemmy-pict-rs does not start with this log: hastebin
lemmy-ui does not start with this log: hastebin

Also here is the screenshot of the upgrade:

Thanks for your help!

1 Like

Please, share the logs of the upgrade.

lemmy-pict-rs log: hastebin
lemmy-ui log: hastebin

For the actual update unfortunately I only got the screenshot:

Thanks a lot!

1 Like

Logs are archived in your webadmin, in Tools > Logs. Select the one, then use the YunoPaste button.

Thank you.
Here is the command I used:

cd /var/www/lemmy/lemmy-ui/

yunohost app upgrade lemmy -u https://github.com/YunoHost-Apps/lemmy_ynh/tree/testing -F

Here is the upgrade log:

Also after the upgrade the following services are not restarting:
lemmy-pict-rs : hastebin
lemmy-ui : hastebin

Thank you very much for looking into this!


The actual error message seems to be Error: Cannot find module '\''@babel/runtime/helpers/extends'\'' but after all these years, those nodejs errors are still kinda cryptic to me …

1 Like

Any update on this?

Thank you,

Today I tried to upgrade to the latest version: 0.18.2~ynh3

got this error: Screenshot-2024-01-10-at-10.09.45AM.png hosted at pic.li - pic.li

and when I run the following yunohost app upgrade got this error: Screenshot-2024-01-10-at-10.18.25AM.png hosted at pic.li - pic.li

And there was no log created for this under the tools.

Hope someone can help :frowning:


1 Like

I stopped the lemmy services and then I was able to update lemmy to the latest version 0.18.2~ynh3
Here is the log: https://paste.yunohost.org/raw/jowuqewidu

The update was successful but the following 2 services are not starting:
lemmy-pict-rs - log: hastebin
lemmy-ui - log: hastebin

Can anyone help with this?


1 Like

Same issues as vidmid

lemmy-pict-rs - log: hastebin
lemmy-ui - log: hastebin

1 Like