Lecteur réseau (WebDAV) ne se connecte pas automatiquement au redémarrage

fr
raspberrypi

#1

Bonjour à tous,

Ceci est mon tout premier post sur ce forum, j’en profite donc pour remercier les développeurs et toutes les personnes qui ont contribué à ce travail.

J’ai récemment tenté l’aventure de l’auto-hébergement. Je suis encore dans une phase de tests, mais je reste totalement satisfait des possibilités et des perspectives que représente l’auto-hébergement. J’utilise mon serveur Yunohost essentiellement pour Nextcloud.

Ma configuration est la suivante :

  • Raspberry pi 3 avec un disque dur me permettant de stocker mes données Nextcloud.
  • Yunohost : 3.4.2.4
    Yunohost-admin : 3.4.2
    Moulinette : 3.4.2
    Ssowat : 3.4.2

A partir de mon Pc (Windows 10), je cherche à accéder à nextcloud en WebDAV. J’ai suivis la procédure décrite dans le manuel utilisateur Nextcloud pour paramétrer un nouveau lecteur réseau (au cours des différentes étapes j’ai coché toutes les options permettant de mémoriser les identifiants ou encore de pouvoir se reconnecter au démarrage). Tout fonctionne correctement, j’ai bien accès à mes fichiers.

Cependant lorsque je redémarre mon pc le périphérique n’est plus accessible. Le message d’erreur suivant m’est renvoyé : “Web Client Network : Nom de réseau introuvable. Cette connexion n’a pas été restaurée”.

Avez-vous une idée sur la procédure à suivre afin que le lecteur réseau se reconnecte automatiquement au redémarrage ?

En vous remerciant pour votre aide.


#2

exactement le même problème chez moi, et ce depuis longtemps, mais je n’ai jamais cherché à creuser…
Je pense qu’il s’agit plus d’un problème relatif au fonctionnement du webdav chez Nextcloud qu’un problème relatif à yunohost.
Peut-être qu’une solution (ou au moins une explication) est disponible sur le forum officiel de nextcloud?


#3

Vu l’erreur ça ressemble à un bug de windows


#4

Effectivement, le problème a bien l’air de provenir de Windows.

Je pense toutefois avoir résolu mon problème, à voir avec le temps la stabilité (j’ai l’impression que cette façon de se connecter à Nextcloud sur Windows est un peu capricieuse).

@Benance, essayez de suivre cette méthodologie :

  1. Réinstaller le lecteur réseau.

Pour le lien utiliser celui situé en bas à gauche de la page d’accueil de Nextcloud après avoir cliqué sur “paramètres”

Cocher les deux options “Se reconnecter lors de connexion” et “Se connecter à l’aide d’informations d’identification différentes”

  1. Dans “Démarrer” > “Panneau de configuration” > “Gestion d’identification” > “Informations d’identification Windows”

Vérifier que les informations d’identification de votre serveur soient bien enregistrées dans “Informations d’identification génériques”.

  1. Dans “Gestion de l’ordinateur” > “Services et applications” > “Services”

Dans la liste, il faut se rendre jusqu’à “WebClient” afin de modifier le type de démarrage à “Automatique”.

Vérifier que le service est bien en fonctionnement, si ce n’est pas le cas il faut le démarrer.

Voilà, en espérant que ça marche dans votre cas.


#6

ok, merci pour le tuyau.
J’ai suivi ta procédure, on verra bien ce que ça donne, mais ça me semble bien être la solution…


#7

Et bien malheureusement, j’ai parlé trop vite. Malgré tes conseils, ce soir, l’erreur de connexion en webdav est de nouveau apparue…


#8

Arf…j’ai du mal à comprendre pourquoi cette erreur est revenue.

Pour ma part, je n’ai pas rencontré de problème de connexion depuis que j’ai suivi la procédure présentée précédemment.

Donc je ne vois pas une autre solution qui pourrait résoudre ton problème. Si j’étais dans ton cas, je supprimerais le lecteur réseau ainsi que les data sauvegardées dans “Informations d’identification Windows” (s’il y en encore après la suppression du périphérique). Puis, je réessayerais de l’installer à nouveau en suivant la procédure pour voir si l’installation est plus stable que celle obtenue au premier essai. C’est une solution sans en être une, et il est vrai que l’intérêt est très limité s’il faut à chaque fois tout réinstaller pour accéder à Nextcloud en WebDav…