Known good admin password does not work on /yunohost/admin

Hi Yunohosterz!

My relatively fresh installed Yunohost (installed apps) works fine, except my Web admin GUI, which refuse my password.
Latest

  repo: stable
  version: 3.6.4.6
yunohost-admin:
  repo: stable
  version: 3.6.4
moulinette:
  repo: stable
  version: 3.6.4.1
ssowat:
  repo: stable
  version: 3.6.4)

on a Debian Stretch (GNU/Linux 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u1 (2019-09-20) x86_64) VPS

I can log into Yunohost web interface as a normal user and use installed apps.
I can log in to the server via SSH and use yunohost commands, including “yunohost tools adminpw” with a reported success and even confirmed by logging in to installed PhpLDAPadmin with the known good admin password, but web admin GUI (at https://myyunohosthost/yunohost/admin/#/login) specifically refuses the same password as “Wrong password”.

Any pointers to the solution would be much appreciated!

It could be a bug with the webadmin and an unsupported character…

Could you check if with different password you have the same issue ? And try to isolate some character that trigger the error ?

Hi ljf,
thanks for that, but unfortunately either it is not the root cause or possibly webadmin is entirely broken, because none of the pw versions tried worked :frowning:
Even my original pw was one without “problematic” chars, but then I tried a few others and, based on your instructions, one with ASCII chars plus numbers (not including zero) and one with only ASCIIs (omitting z and y to rule out qwert* keyboard problems), but unfortunately none worked.
(I cross-checked all of them in PhpLDAPadmin and I could log into PhpLDAPadmin as admin user and even tested with it’s “Check password …” utility - all success).

Just to add: the problem arose after the failed (as I remember) install of one of the addon softwares (but unfortunately I can’t recall wich one).

You can found the software you have triued to install by running :

yunohost log list

Something about “Install fail”

And you can found the end of the log by doing:

yunohost log display NAME_OF_LOG

Thanks, that’s very handy indeed!
I found four failed installs:

root@devnyul:~# yunohost log list | grep failed
    description: Remove 'portainer' after a failed installation
    name: 20190908-201057-remove_on_failed_install-portainer
    path: /var/log/yunohost/categories/operation/20190908-201057-remove_on_failed_install-portainer.yml
    description: Remove 'pgadmin' after a failed installation
    name: 20190908-202804-remove_on_failed_install-pgadmin
    path: /var/log/yunohost/categories/operation/20190908-202804-remove_on_failed_install-pgadmin.yml
    description: Remove 'peertube' after a failed installation
    name: 20190908-203054-remove_on_failed_install-peertube
    path: /var/log/yunohost/categories/operation/20190908-203054-remove_on_failed_install-peertube.yml

Still a bit lost with my un-trained eyes though :frowning:
Could you please help in what to look for in that logs?
Or possibly can I upload it somewhere zipped and you could help decode it?
Your help is much appreciated!

Could you check yunohost-api service is up ?

Yes, API service looks fine based on status check:

root@devnyul:~# yunohost service status yunohost-api
active: active
active_at: 2019-10-02 21:02:57
description: manages interactions between the YunoHost web interface and the system
loaded: enabled
service_file_path: /lib/systemd/system/yunohost-api.service
status: running

What’s up with (other) services, that are enabled, loaded, but “exited”?

For postfix and some others it’s ok

Uploaded zipped logs of failed install/uninstall pairs, just in case someone could review them and point some direction for debugging or possibly give a solution.
Here:
https://arslon.ga/lufi/r/9QGBK6MwzF#lTF5UddEr1d3r54YnsAqMNUmQnvGn92JWxRQGBoFKFc=
Thanks!

Personnaly i don’t understand why you have this behaviour.

Try to restart yunohost-api:

service yunohost-api restart

If it doesn’t work try:

apt remove --purge yunohost-admin
apt install yunohost-admin

Please: before to confirm this command, check it doesn’t deinstall yunohost package…

Ohhh My! that API service restart ( ```
service yunohost-api restart


Could you please shed some light on what could have happened to that yunohost instance and how this API service thingie works (or does not work :wink: )
Just curious, because no "simple" server-restart ever helped.

Anyways, thanks alot, your help is much appreciated!