KiwiIRC Software error following supposedly successful install

Hi there happy new user of YUNOHOST and have successfully installed a handful of services on a newly installed VPS server. Now I am having some issues with IRC clients

My YunoHost server

Hardware: Vultr VPS
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

While I intend to install The Lounge after reading documentation on the various irc clients, I have came across a bug on the current version.

In the meantime I tried Kiwi IRC which installed without error and seems to be running in the Services screen with no errors in the log

-- Logs begin at Fri 2021-11-12 18:54:47 UTC, end at Fri 2021-11-12 21:24:09 UTC. --
Nov 12 19:04:11 systemd[1]: Started Websocket gateway to IRC networks.
Nov 12 19:04:11 kiwiirc[13063]: 2021/11/12 19:04:11.174338 Using config /var/www/webircgateway/config.conf
Nov 12 19:16:57 systemd[1]: Stopping Websocket gateway to IRC networks...
Nov 12 19:16:57 systemd[1]: kiwiirc.service: Main process exited, code=killed, status=15/TERM
Nov 12 19:16:57 systemd[1]: kiwiirc.service: Succeeded.
Nov 12 19:16:57 systemd[1]: Stopped Websocket gateway to IRC networks.
Nov 12 19:16:57 systemd[1]: Started Websocket gateway to IRC networks.
Nov 12 19:16:57 kiwiirc[19644]: 2021/11/12 19:16:57.314094 Using config /var/www/webircgateway/config.conf

When I actually attempt to open the web app, the page returns an error.

Kiwi IRC could not start :(
Config file error: invalid character '<' line 1, position 1

and below is the contents of the config in the last line of the log

> cat /var/www/webircgateway/config.conf
# 1 = Debug; 2 = Info; 3 = Warn;
logLevel = 3

# Enable the built in identd server (listens on port 113)
identd = false

# The name of this gateway as reported in WEBIRC to IRC servers
gateway_name = "webircgateway"

# A secret string used for generating client JWT tokens. Do not share this!
secret = ""

# Send the server a quit message when the client is closed
# Comment out to disable
send_quit_on_client_close = "Client closed"

recaptcha_url = ""
#recaptcha_url = ""
recaptcha_secret = ""
recaptcha_key = ""

# If required, a client must always pass a captcha challenge before making an IRC connection
required = false

# Default username / realname for IRC connections. If disabled it will use
# the values provided from the IRC client itself.
# %a will be replaced with the users ip address
# %h will be replaced with the users hostname
# %i will be replaced with a hexed value of the users IP
# %n will be replaced with the client provided nick
username = "%i"
realname = "I am a webchat user"

# This hostname value will only be used when using a WEBIRC password
#hostname = "%h"

# The websocket / http server
bind = ""
port = 80

# Example TLS server
#bind = ""
#port = 443
#tls = true
#cert = server.crt
#key = server.key
# If you don't have a certificate, uncomment the below line to automatically generate a
# free certificate using (overrides the above cert/key options). This requires
# a server running on port 80 to initially generate the certificate.
#letsencrypt_cache = ./certs

# Example unix socket server
bind = unix:/tmp/webircgateway.sock
bind_mode = 0777

# Serve static files from a web root folder.
# Optional, but handy for serving the Kiwi IRC client if no other webserver is available
enabled = true
webroot = www/


# Websites (hostnames) that are allowed to connect here
# No entries here will allow any website to connect.
# Origins do not include a trailing / after the host and optional port

# If using a reverse proxy, it must be whitelisted for the client
# hostnames to be read correctly. In CIDR format.
# The user IPs are read from the standard X-Forwarded-For HTTP header

# Connections will be sent to a random upstream
hostname = ""
port = 6697
tls = true
# Connection timeout in seconds
timeout = 5
# Throttle the lines being written by X per second
throttle = 2
# Webirc password as set in the IRC server config
webirc = ""
serverpassword = ""

# A public gateway to any IRC network
# If enabled, Kiwi IRC clients may connect to any IRC network (or a whitelisted
# network below) through the kiwiirc engine
enabled = false
timeout = 5
throttle = 2

# Whitelisted IRC networks while in public gateway mode
# If any networks are in this list then connections can only be made to these

# Webirc passwords used when running in the public gateway mode
[gateway.webirc] = webirc_password = webirc_password

# "verify" - if the client supports it, tell it to show a captcha
# "deny" - deny the connection entirely
action = deny


I think somebody had the same issue recently, there’s a unix permission / ownership issue with the config

What does ls -l /var/www/webircgateway/config.conf returns ? Or even namei -l /var/www/webircgateway/config.conf

I saw something similar on its git hub issue 6

initially config.conf was kiwiirc:kiwiirc, which was different than the other files in the directory ‘config.conf.example’ and the ‘kiwiirc’ binary were both owned by kiwiirc:www-data.

I tried chown kiwiirc:www-data /var/www/webircgateway/config.conf and rebooted kiwiirc service and then even rebooted the server but nothing changed. Is this something that requires a recompile after changing?

I agree.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

I tried to fix Kiwiirc. This version in testing should work. Please test and report back

sudo yunohost app install

Edit. I guess the config files needs to be adapted