KimaI 2 - "Missing permission"-bug, when logging time

I installed Kimai 2 (2.15.0~ynh1) on my YunoHost (stable). It works, but everytime I try to create a new time entry I always get the error message “Missing permission. Redirect to login?” although I’m logged in as an admin and have all the necessary rights. When I cancel the error message, I can enter the time, but this is annoying.

When I create new users, they get the same error message, even when they are allowed to create time entries.

Bildschirmfoto 2024-04-28 um 19.29.00

Hello, I had the same problem after updating Kimai2 to 2.15.0~ynh1.
After changing user permissions in the System => Roles menu (in Kimai2), the tool works again.
I think it’s because your users don’t have the right permissions, so you should look that way.
I’m sorry but I don’t remember the settings I checked in the System => Roles menu of Kimai2, but I think this is the solution.

Thanks for your advice. I tried this and changed the roles, put everything on green, even added a new user and teste new roles, didn’t change anything for me. I still get die “Missing Permission” bug

Hi @zohan, sorry to read that.
Does this problem occur when you are logged in with a Super Admin user ?


I have the problem again on my account and on the accounts of colleagues. What is surprising is that in Private Browsing, it works, the warning does not appear. However, I must connect directly to Kimai2 without going through the Yunohost connection portal.
Is this happening the same for you?

No, I tried it in Safari and in Firefox, didn’t work.