KeeWeb to manage passwords


#42

Hello, thx @spooknik !! Did you downgrade your Yunohost installation to resolve it ?


#43

No, I am still on 3.3.4 (not sure if I can downgrade?)

I used the custom web app , then transferred (via sftp) the contents of the install package to the root of the web app. It’s not so elegant, but it works until the official app can be fixed.

Edit: Linked the wrong package


#44

I reproduce myself, nginx says “[error] 3520#3520: *4 open() "/var/www/keeweb/app/js/app.js" failed (2: No such file or directory)
Indeed, this file doesn’t exist.

This package use the version 1.6.3 of keeweb, but there was recently updates on this app.
Maybe using a more recent version could fix that issue.
What’s strange by the way is that this issue wasn’t there before, and nothing change on this package since…

Anyway, I’m not the maintainer of this app. I just worked on it because I wanted to use it.
Fell free to update this package. Also, if one of you want to maintain this app or make any PR on it, don’t hesitate to ask for permissions on this repo.


#45

I’ve forked the repo on Github and am updating it with this source. It’s the official download recommended by the author for self hosting. It’s much simpler than the package being downloaded now.

We’ll see how it goes, web apps aren’t really my forté.

Edit @martoni35 If you want you can try to install this version and tell me if it works for you. It’s working for me on 3.3.4


#46

Hello,

Your fork is nice in 3.3.4 :
image

Everything is OK !!
Only one mistake, yunohost is down with Firefox but OK in private…and OK with Chrome since this app add… :frowning:

martoni


#47

Just tested, loaded my keepassx file (on nextcloud :wink: ).

Seems OK for now


#48

@martoni35 Not sure what the problem is. Maybe you can try to clear the browser cache? I tried in firefox and chrome, both work fine for me.

@Shnoulle Good to hear, let me know if any problems come up.


#49

Hello,

@spooknik
First step, I cleared my browser and i closed it : nothing better.
Then, i turned off my computer and nothing better.
With a mode private with the same browser, it’s work !! And with Chrome, it’s work !

martoni


#50

Hi @spooknik, I have tried with your repository.

  • The installation works
  • The app loads correctly and works for local files
  • I still have “network error” when I try to load the WebDAV path

I have installed the app on the root of my subdomain -> do you think it could be related to the problem ?
I have installed the app as a private app -> do you think it could be related to the problem ?


#51

Hello, thanks for letting me know.

My first guess would be no to both because I don’t think it would make a difference. But i’ll test both just in case.

Something to try might be using the webdav on the official app and see if that works. If yes, then your webdav setup is correct and the problem is with our keeweb. If no, then perhaps it could point to a problem your webdav setup.

Eitherway, I will do some of my own testing and report back.

Edit: Initially I was having similar problems with ‘network error’ and then a ‘401’ error. But now it seems to be working find for me. The app is installed as not public. I’m using Nextcloud for webdav and used the following link: https://example.com/nextcloud/remote.php/webdav/Database.kdbx then I enter my username and password.

Edit2: You don’t actually need to enter your user name and password to load the database from webdav. Yunohost should already have that figure out.