Kanboard installation error?


I am trying to install KanBoard, but I get errors.

What should I do ?

Thank you.

there is the log :

  • set -e

  • app=kanboard

  • domain=www.randome.camp

  • path=/kanboard

  • admin=feydreva

++ sudo yunohost user info feydreva

++ sed ‘s/mail: //g’

++ grep mail:

  • email=feydreva@randome.camp

  • sudo yunohost app checkurl www.randome.camp/kanboard -a kanboard

++ openssl rand -hex 15

  • db_pwd=xxxxxxxxxxxxxx

  • sudo yunohost app initdb kanboard -p xxxxxxxxxxxxxxx

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

Error: MySQL database creation failed

Did you change your MySQL password manually ?
Is MySQL running ? You can use the command sudo systemctl status mysql.service or sudo service mysql status to see.
Can you connect to mysql with the command mysql -u root -p$(sudo cat /etc/yunohost/mysql) ?


I do not remember changing the password for Mysql.

MySQL service seems to be running :

admin@arm:~$ sudo systemctl status mysql.service
● mysql.service - LSB: Start and stop the mysql database server daemon
Loaded: loaded (/etc/init.d/mysql)
Active: active (running) since Mon 2015-12-28 23:51:03 CET; 8h ago
Process: 459 ExecStart=/etc/init.d/mysql start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/mysql.service
├─ 746 /bin/sh /usr/bin/mysqld_safe
└─1130 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --log-error=/var/lib/mysql/arm.err --pid-file=/var/lib/mys…

Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: roundcube.contactgroups OK
Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: roundcube.contacts OK
Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: roundcube.dictionary OK
Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: roundcube.identities OK
Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: roundcube.searches OK
Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: roundcube.session OK
Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: roundcube.system OK
Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: roundcube.users OK
Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: wordpress.wp_commentmeta OK
Dec 28 23:51:12 arm /etc/mysql/debian-start[1268]: wordpress.wp_comments OK

And I cannot conect to it :
admin@arm:~$ mysql -u root -p$(sudo cat /etc/yunohost/mysql)
ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

I can connect to mysql using debian-sys-maint and the associated password given in /etc/mysql/debian.cnf
but I cannot connect using admin or my main user.

I tried to install phpMyAdmin, it installed correctly but I get an Access Denied error.

Tahnk you for you Help.


Any help ???

Still stuck with the same error

Well, the error is not very related to kanboard and should be the same with every app that use mysql.

You have a mysql issue since you can’t connect with the root user. I don’t know the solution for this.
First you can try to restart mysql, maybe reboot your server if you didn’t already try that.

If nothing works you can try to change mysql root password using something like this http://superuser.com/a/603027
Be careful, yunohost use the root password in the file /etc/yunohost/mysql so once you changed mysql password you have to write the new password to this file too.

I do not know how other apps were connecting to mysql… but it was working propoerly for them…

I resetted the root password using the linked you shared, and used the same pswd that was on the /etc/yunohost/mysql file.

Installation of Kanban is now successfull :slight_smile: :slight_smile: