Joomla database tables issue

  • READ ME AND USE THIS TEMPLATE IF YOU WANT TO GET HELP ! You may ask your question in english or french, whichever is easiest for you… But please use one of the templates provided below :wink:
  • LISEZ-MOI ET UTILISEZ CE MODÈLE DE TOPIC SI VOUS SOUHAITEZ OBTENIR DE L’AIDE ! Vous pouvez poser votre question en anglais ou français, selon ce qui est le plus simple pour vous… Mais de préférence en utilisant l’un des deux modèles fournis ci-dessous :wink:

:uk:/:us: Message template (english)

The “support” category is meant to ask for help or troubleshooting related to installing or using YunoHost or its applications. It is not to ask assistance on general system administration, network administration or special use cases that goes beyond the scope of the project. If you wish to discuss more advanced use case, please post in the “Advanced Use Case” category.

Before posting, please :

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

Installation of Joomla works perfectly and instance runs, BUT. Joomla shows an update available and is unable to update due to “Database Table” issues, click on the menu option to fix (menu option is greyed out…this is a Joomla issue I think). Also, default upload size is @ 2M meaning have to edit numerous files to be able to upload any modules/extensions. Once that’s sorted extensions crash the system anyway or don’t install. On top of that, there’s the annoying you shouldn’t be using php 7.3 at least 7.4 message in bright red.

Has anyone recently installed joomla successfully and able to share their secrets to get it working?


1/ you should not update directly from joomla, wait some days and you’ll get it in yunohost.
2/ increasing max upload size can be done by editing /etc/php/7.4/fpm/pool.d/joomla.conf , find php_admin_value [upload_max_filesize] and php_admin_value [post_max_size] uncomment them (by removing the ; ) and restart php7.4. What’s confusing here is that the php version is 7.4 but joomla is showing a warning about older version and when I open the info tab in joomla it show php 7.4.28 :upside_down_face: . Another thing is I couldn’t upload files larger than 1M even after changing the max file size. The warning has disappeared but I still get the warning about the tmp folder.
So I tried to check in joomla settings > global > server , the tmp path is correct, but when I clic save, it “crashes”. It seems it lost its connexion to the database. I didn’t investigate further.
The error page is full of info, some of the error messages :

Table 'joomla.jos_template_styles' doesn't exist ...
**Warning** : session_write_close(): Failed to write session data using user defined save handler. (session.save_path: /var/lib/php/sessions) in **/var/www/joomla/libraries/vendor/joomla/session/src/Storage/NativeStorage.php** on line **114**

I think you should be careful and make backups if you made a lot of work on it in case.

Yeah, seems to be rather buggy… Will have to see if there’s some other way to get it running. hopefully someone will pickup the app and start to maintain it again

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.