Jitsi-meet cannot be installed with Yunohost?

:uk:/:us: Message template (english)

My YunoHost server

Hardware: VPS bought online / laptop and computer /
YunoHost version: 4.2.4
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain:

Description of my issue

Jitsi-meet cannot be installed with Yunohost ?

Version: YunoHost 4.2.4 (stable)
Installed on a VPS from Debian 10.
Precision: I also tried to make the manipulation on other servers without any success.

Hello there :slight_smile:

As Jitsi-meet is no more available and maintained, I tried to install it in parallel of my Yunohost install in the same server. It is pretty basic but I also tried other methods.

I got this all the time if I have Yunohost installed on my server:

    The following packages have unmet dependencies:
     jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.4985-1) but it is not going to be installed
                  Recommends: jitsi-meet-turnserver (= 1.0.4985-1) but it is not going to be installed or
                              apache2 but it is not installable
    E: Unable to correct problems, you have held broken packages.

I tried: to repair aptitude, to modify my deb/sources, to purge, to install jitsi-meet-prosody (impossible too, as probably other packages), etc.
The only solution I found it is to “apt install prosody” BUT it remove many packages and break Yunohost-api.

So, is there a known conflict in packages ?
And, is there another way to do that ?

Thank you…

:fr: Modèle de message (français)

apache2 but it is not installable

Yup, YunoHost relies on NGINX. Installing Apache would break everything. We had a packager trying to create an app for Jitsi for months… he threw in the towel. :frowning:

Ah… :frowning:
But I don’t even want to create an app, just install without passing through YunoHost.

It seems to be possible :

" Install Jitsi Meet

Note: The installer will check if Nginx or Apache are present (in that order) and configure a virtual host within the web server it finds to serve Jitsi Meet.

If you are already running Nginx on port 443 on the same machine, turnserver configuration will be skipped as it will conflict with your current port 443."

So, something is wrong or in conflict with Yuno.

Using nginx instead of apache is probably easy, the major issue is that jitsi-meet is kinda tight-coupled to prosody, while yunohost uses metronome. Even if metronome is a fork of prosody, the two packagers that tried to package the app had too many mystic issues … Maybe you can end up getting things working, but be prepared for some non-trivial tinkering and loosing some mental sanity …

Feel free to browse the PR and issues in GitHub - YunoHost-Apps/jitsi_ynh: Video conference for YunoHost

Second part of the issue is that Jitsi Meet is known to only work well on Chrome … though maybe that got improved recently, i dunno

Many thanks for this feedback. That definitely explain the issue.
I think the solution is to use docker compose with Jitsi in a separate container.
I am trying and it seems to work…
I will let you know :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.