Jellyfin update error

,

:uk: Hi everyone,

I tried updating Jellyfin from the admin panel, from version 10.6.4~ynh2 to 10.7.5~ynh1. When I tried it the first time, it told me there was an error with the /var/lib/jellyfin/logging.json file being unreadable. So I went and check and indeed, it did not exist. You can check the log for this install right here:
https://paste.yunohost.org/raw/hafuboxohe

So then I just tried creating this file by hand with a sudo touchand adding some rights to the file with chmod +rxw and retried the installation. This time it appears this installation did not fail, but now when I try to access Jellyfin I have a 502 bad gateway error.

So I do not want to break everything even more so I’ll just wait for someone’s input to take further steps. Thanks in advance!

:fr: Bonjour tout le monde,

J’ai essayé de mettre à jour Jellyfin depuis la webadmin, pour passer de la version 10.6.4~ynh2 à la 10.7.5~ynh1. Quand j’ai essayé la première fois, j’ai eu une erreur avec le fichier /var/lib/jellyfin/logging.json qui était inaccessible. J’ai donc vérifié et en effet, il n’existait pas. Vous pouvez consulter le log de cette installation ici :
https://paste.yunohost.org/raw/hafuboxohe

J’ai donc essayé de créer ce fichier à la main avec un sudo touch et d’ajouter des droits au fichier avec chmod +rxw et j’ai retenté l’installation. Cette fois, il semble que l’installation n’a pas échoué, mais maintenant lorsque j’essaie d’accéder à Jellyfin j’ai une erreur 502 bad gateway.

Je ne veux pas tout casser, donc je vais attendre l’avis de quelqu’un pour prendre d’autres mesures. Merci d’avance !

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 4.2.5.2 (stable)
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Thank you for your report ! There is a testing release to fix the problem with the log file. However, for your subsequent issue, can you try restarting the Jellyfin service and share the journalctl -xe log ?

I have restarted the service but i’m not sure what’s the best way to share this log with you… I have it opened in my terminal, but it’s to long to be copy/pasted…

Edit: Sorry, found it!
https://paste.yunohost.org/kelibohugo
https://paste.yunohost.org/oxotulileh

dont’ know if this is usefull but here is some info about the file mentionned in the log:

$ sudo ls -la "/var/lib/jellyfin/plugins/LDAP Authentication/"
total 256
drwxr-xr-x 2 root     root       4096 May 31 12:36 .
drwxr-xr-x 4 jellyfin jellyfin   4096 May 31 12:36 ..
-rw-r--r-- 1 root     root      27136 Dec  5 14:48 LDAP-Auth.dll
-rw-r--r-- 1 root     root        886 Dec  5 14:48 meta.json
-rw-r--r-- 1 root     root     214016 Dec  5 14:48 Novell.Directory.Ldap.NETStandard.dll

ok so I just chown-ed the file:
$ sudo chown jellyfin:jellyfin "/var/lib/jellyfin/plugins/LDAP Authentication/meta.json"
and now it works!

Thanks for your help, if you have anymore advice, I’d gladly take it.

Thank you for your reporting and investigation. :slight_smile: I will check the code of the app, these should not have belonged to root.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.