Jellyfin dead and won't restore

Hello all,

I noticed that few weeks back Jellyfin service was dead and would not restart. There were no logs, just that systemd service was not found if I remember correctly. When trying to access it through the browser I got a 502/nginx error.

So I uninstalled it and tried to restore it though the latest backup I had, but without success.

Below the log from the restoration process.

https://paste.yunohost.org/raw/nopogoruso

Any help?

Appear systemd unit file was deleted before backup creation. Try creating the missing file with the following command

sudo nano /lib/systemd/system/jellyfin.service

And add the following content

[Unit]
Description = Jellyfin Media Server
After = network.target

[Service]
Type = simple
EnvironmentFile = /etc/default/jellyfin
User = jellyfin
ExecStart = /usr/bin/jellyfin ${JELLYFIN_WEB_OPT} ${JELLYFIN_RESTART_OPT} ${JELLYFIN_FFMPEG_OPT} ${JELLYFIN_SERVICE_OPT} ${JELLYFIN_NOWEBAPP_OPT}
Restart = on-failure
TimeoutSec = 15

[Install]
WantedBy = multi-user.target

Then try restoring backup again

Hi, thanks for your reply.

Unfortunately it did not do the trick…

https://paste.yunohost.org/raw/lukeyuvibu

You can try the following command

sudo ls /lib/systemd/system

if you get a directory list you can reinstall Jellyfin from an earlier backup or from scratch. If you get a “not such file or directory” error then you need reinstall your yunohost server due something broke systemd and your server will stop working when you reboot it

There is a directory there. I tried to nano the text you mentioned but ended up to be somehow deleted (?), was not there.
In any case, I installed it from scratch and it works now.

Thank you for your help.