It´s possible to install Yunohost in a C.H.I.P. 9$ computer?

Hi, I´m asking for help to install Yunohost in a CHIP computer.

Thanks in advance! :innocent:

I do not think we have an OS image for that, but if you can first install Debian 10 “Buster” on it, then follow the documentation for installing YunoHost on other servers. It’s one simple command line.

You will need to check that your server’s specs are enough to run YunoHost.

Hello, thanks for your quick response

Have you tried following the error message’s advice and rebooted the server?

As mentioned by @tituspijean, it should work if you start with plain Debian 10. I tried to find an image for Allwinner A13 at the Armbian site, but could not find any.

Debian will run, Openmoko GTA04 / Letux 2804 runs (an older version of) Debian with almost the same CPU and is … usable. It is not fast. The CPU is single core.

It is nice if you can use the CHIP for this goal. If it is an option for you, Orange Pi Zero is/was about 9$ as well, but with a 4-core CPU and no storage. It does have ethernet.

I ran Yunohost on Orange Pi Zero with ‘no problem’ for small groups of people. RAM is the first problem at 512 MB. I would make a swap file or partition of 512 MB; more than double that amount does not make sense.

Please post your results!

Hi, thanks for your responses.

The first problem was upgrade CHIP from debian lenny to debian buster, but finally it works. Then I installed Yunohost, but in the step of postinstall shows an error "Need more than 10GB in the root partition, and CHIP have 8GB of internal storage. About 6GB free.

I don´t know what I can i do. :roll_eyes:

I don’t know how space is checked, and why it stumbles. The installed system does not need so much space (but without space, many things are not so useful).

Do you know SSHFS? You could try mounting a directory on another computer. Maybe the free space will be added to the total.
You could try inserting a USB drive?

Thanks for response.
I have a pendrive 32GB Sandisk, I inserted it but I don´t know how to configure it.

Do you know how to access your Yunohost via SSH, and get around?

Yes, I can access by SSH and use the console, but I’m not an expert

Ok! By default, Yunohost creates user admin with sudo rights.

  • Insert the pen drive and log in with admin@youryunohost
  • sudo fdisk -l
  • note the output;
    • Embedded storage is often mmcblk, something like that
    • I’m not sure how the pen drive will show up. I’ll use /dev/sdb1 as example
    • Looking at the size of the partitions you can probably guess
  • To check whether the pendrive is mounted automatically, there are (at least) two options:
    • df -h # gives a list of mounted partitions and their size
    • mount gives a list of mounted partitions
  • As said, I have no idea how post-install calculates and checks available storage. For trying out:
  • mkdir /home/pendrive
  • mount /dev/sdb1 /home/pendrive
  • I am not sure you can restart the post-install, it sets a marker somewhere. Give it a try?

If you get stuck, please post the result of sudo fdisk -l and of sudo df -h.


Still the same error message :roll_eyes:

Ok, I see that the pen drive is listed as /dev/sda1, and mounted at /media/sandisk32.

Now the idea is to not let Yunohost know that it is removable storage for now, and add it to the system, more or less. I see root, not admin, so I’ll leave sudo out:

  • umount /dev/sda1
  • mkdir /home/pendrive
  • mount /dev/sda1 /home/pendrive

And then try again.

If it still does not work out, you could restart the complete installation of course and use the pen drive instead of the embedded memory. That will block your USB port for other uses though (and you’ll need to buy another pen drive for your key chain :-P)

Let´s do it. Thanks! :rofl:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.