Issue: Yunohost installation on freenas bhyve virtual machine, cdrom device not recognised

Hi everybody,

Here’s my goal:
Install Yunohost from a pre-installed iso image of yunohost to a bhyve virtual machine on my freenas.

My issue:
I can connect to the VM, but the cdrom device is not recognised. I’m unable to boot on it, I’m only accessing the efi shell of bhyve.

My steps:
1 - I have succesfully installed other VMs on my freenas, such as debian jessie 8.10 and debian stretch 9.4, both with official amd64 iso.
2 - I have succesfully installed Yunohost on the virtual Jessie distrubution, as explained in the manual installation for VPS.
3 - I have downloaded the Pre-installed stable Yunohost amd64 iso onthe page https://build.yunohost.org/.
Checksum ok.
From this image, I’m unable to boot my virtual machine on the cdrom, but when I change the Ynh iso in cdrom device for the debian 8.10 iso, it works just fine!! Strange isn’t it!?

Of course, I still can install Yunohost with the manual procedure, I’m not completely stuck. I’m surprised the simple way is not fonctionning. Maybe someone has an idea.

I’ve already read the other forum topics about the grubx64.efi file to copy in another directory. Works only if you have already a system installed on your VM. Not relevant for my issue.

My issue is the same than this one:


And of course I also tried this:

Thanks to all!
I both speak english and french

Hi,
First of all I forgot to mention my hardware:
A dedicated computer as server with an Asrockrack server motherboard.
Pentium G3460 as CPU.
Last Freenas on it, running on usb key as recommended.
Here’s what I found, maybe nothing much or unknown, you tell me:
I compared official images of Debian8, Debian9 and Yunohost.
I mount them on my windows pc with the option “Mount as ImDisk Virtual Disk”, not Daemon tool.
Mount%20as
For both Debian 8 and 9 images, a window pops, asking me wich partition I want to mount!
I have a choice between 2 partitions, one more than 250Mo, and another small one, few Ko.
Debian8
Debian9
I don’t have the same choice for Yunohost image. No small partition, directly mounted as virtual cd drive.
So on Debian images I chose to mount the small partition, to see what happen.
It ends with a virtual drive mounted of 400Ko.
Small%20partition
Inside, one file on a directory: /efi/boot/bootx64.efi


For Yunohost image, nothing like that on a separated dedicated partition. Of course I can find this very same file on the usual image of Yunohost, as well as on the usual image of Debian versions.

After that, I tried to mount same images on Macos Finder. Impossible to mount Debian images, no problem for Yunohost image.

Well, I found those differences, don’t know if it worth something, and I’m wondering if by any way it can have an impact on boot sequence for bhyve virtual machines.

Thanks to all!