Issue with Wordpress and PHP memory

not sure what i need to do but the default "changing wordpress memory from 40M to 128M in wp-config.php doesn’t work… and nor does it work when changing the php.ini in /etc/php/7.0/fpm/php.ini or in php.ini in the webapp’s location and apparently the default is 30M which isn’t normal or default. so maybe yunohost is doing some special PHP config elsewhere?

basically, i need to raise php memory_limit and not sure how

But why do you want to do this :confused:

because i have a really nice professional wordpress theme and it requires raising the limits a bit for all its plugins to work. which, i guess they work fine. i guess what i did worked the theme itself just doesn’t see that it worked apparently. which is annoying and stuff is still disabled but i think now its the fault of the theme in specific not being able to see the php info or something.

either way as for “why”, i wanted to modify it to make a really “professional” website for my business… with parallax sliders and whatnot.

To change the value in the specific fpm pool for wordpress should be enough.
At the end of etc/php/7.0/fpm/pool.d/wordpress.conf, modifying the line php_admin_value[memory_limit] should be ok.

To be sure, you can try the plugin https://wordpress.org/plugins/php-server-info/

1 Like

that worked perfectly! thank you so much!

Hi!
Just to say that there is more and more themes and plugins in Wordpress that require at least 64MB of memory for PHP usage.
And to add to not forget to restart your php-fpm to take into account the new PHP settings:

# /etc/init.d/php7.0-fpm restart

As simply restart nginx is not enough.

@Leo if you want give your point of view I suggest this change on the package: https://github.com/YunoHost-Apps/wordpress_ynh/pull/69

1 Like