Issue with restore command, it doesn't work as described in the documentation?!

,

Hi, well this might not be a bug. But it but the restore command which is described here: Backing up your server | Yunohost Documentation doesn’t seem to work, as i try to restore wordpress__3.

I enter the command:
yunohost backup restore --apps wordpress__3
This is in the documentation:
yunohost backup restore --apps wordpress

But then i get the answer:

usage: yunohost backup restore name
                               [-h] [--system [SYSTEM [SYSTEM ...]]]
                               [--apps [APPS [APPS ...]]] [--force]
yunohost backup restore: error: the following arguments are required: name

Huh?! :thinking: am I missing something here?

For more info :
sudo yunohost backup - - help

To list the backups :
sudo yunohost backup list

1 Like

Hi thanks but list shows the archives only, which the WordPress backup is in so, I’m right with the command right? Or does it only work if there is a sole backup of that app, so not a complete backup but one specific for WP__3?

As the message says, you need to provide the archive name …

1 Like

But where? Because the documentation says:
yunohost backup restore --apps wordpress

So you like this?
yunohost backup restore --app 20210916-205412 wordpress__3

That gives the same error back.

Sorry for the hard time understanding here :frowning:

yunohost backup restore 20210916-205412 --apps wordpress__3

1 Like

OMG… Yup that worked!

Thank you a million times @Aleks where would I be without you :flushed: :innocent:

Documentation to be fixed with Clarify backups list and specific restore by tituspijean · Pull Request #1786 · YunoHost/doc · GitHub :innocent: .

3 Likes

Finished :smiley: thanks again guys also for clarifying the documentation!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.