IPv6 stopped working

Hi everyone! I have run into an issue that I’m hoping someone here can help me with. Apologies in advance, I am very new to self-hosting, so it’s entirely possible I’m overlooking something very obvious.

My YunoHost server

Hardware: VPS bought online from German provider easyname.de
YunoHost version: 11.1.20
I have access to my server : through SSH and the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no (not that I know of)
If yes, please explain:

Description of my issue

I got an email that my Let’s Encrypt certificate couldn’t be renewed because “The DNS records for domain ‘[my domain]’ are different to this server’s IP”. I ran the diagnosis tool, which says that the server does not have a working IPv6 address. My server does have IPv6 though, and until a couple of days ago Yunohost had recognized that (that is why I have a DNS record pointing to my server’s IPv6 address). Now it seems like IPv6 has stopped working, even though I haven’t made any conscious changes.

What I’ve tried so far

I connected through SSH and tried some commands I found through googling to check whether IPv6 is working on the server, but I’m not quite sure how to interpret the results (again, very new to this, sorry if this is all useless).

hostname -I returns: 2a01:aee0:2:1::5e

ip a returns:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: venet0: <BROADCAST,POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default 
    inet scope host venet0
       valid_lft forever preferred_lft forever
    inet brd scope global venet0:0
       valid_lft forever preferred_lft forever
    inet6 2a01:aee0:2:1::5e/128 scope global 
       valid_lft forever preferred_lft forever

pinging an IPv6 server as recommend here gets stuck on:

PING ip6.yunohost.org(yunohost.org (2001:910:1410::1)) 56 data bytes

So, yeah, I don’t know what to make of this. Is this a Yunohost problem or a problem with my hosting? Any pointers would be appreciated.

IPv6 spontaneously stopping to work is kind of not surprising :sweat_smile: Not that there are any specific reason for this but this seems to be the kind of thing that spontaneously break more often than others :stuck_out_tongue_winking_eye:

Anyway, seeing

I would ask “what makes you so sure of this”

There’s a difference between the server thinking it has an IPv6, and IPv6 effectively working.

The only reliable test is to ask another server on the internet to return what it sees as your IP, such as using

curl https://ip6.yunohost.org

(or any similar micro-service that achieves a similar function)

If this does not work, then IPv6 is not working

In 90% of cases, this ain’t due to YunoHost, as YunoHost doesn’t really configure anything related to the low-level network stack, it just tries to diagnose wether or not it’s working. The issue is usually related to your ISP (or VPS hoster) OR it could be because the firewall is misconfigured, maybe due to some manual tweaking, or due to some specific app such as VPNclient, or maybe Docker could interfere with iptables etc…

Thank you, this was helpful!

curl https://ip6.yunohost.org


curl: (28) Failed to connect to ip6.yunohost.org port 443: Connection timed out

That port is set to open in Yunohost’s Firewall settings. Does that point to the issue being with my VPS hoster?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.