[IPV6] : outil diagnostic indique que le serveur n'a pas d'IPV6

Mon serveur YunoHost

Matériel: Odroid N2.
Version de YunoHost: 4.0.7 (stable)
J’ai accès à mon serveur : En direct avec un clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : Routeur synology RT2600ac + VPN FDN (IPV4 et V6 fixe) + Freebox (routeur en DMZ)

L’outil diagnostic indique dans la partie “connectivité internet” :

Le serveur ne dispose pas d’une adresse IPv6.
L’utilisation de IPv6 n’est pas obligatoire […] problème.

Précisions :

  1. je suis débutant sur toutes ces questions réseau (et debian en général) ; donc ne pas hésitez à m’indiquer, si vous en avez le temps bien sûr, les manips/contrôles les plus évident(e)s pour vous :slight_smile: ;
  2. côté Freebox : IPV6 activé => automatique depuis quelques années à mon sens ;
  3. côté routeur : dans centre réseau/internet/configuration d’IPV6 : j’ai indiqué dans :
    3.1 : configuration d’IPV6 : auto
    3.2 : l’adresse IPV6 indiquée en dessous est différente de celle du VPN FDN (ce qui me semble logique) ;
    3.3 : le site ipleak;net ne me renvoit que mon IPV4 public

Merci bcp !

1 Like

Ébééé on peut commencer par double-check en faisans sur le serveur via SSH / ligne de commande :

curl ip6.yunohost.org

Hello Aleks,

La commande curl ip6.yunohost.org donne :

curl: (7) Couldn’t connect to server

Donc si je comprends bien tu as un VPN FDN installé sur ton serveur à l’aide l’app vpnclient j’imagine …?

Dans ce cas le fait que tu ai de l’IPv6 sur ta freebox ne change pas forcément la donne …

Perso je comprends pas trop pourquoi l’IPv6 ne fonctionne pas, naïvement je commencerais par demander aux gens de FDN si c’est normal que l’IPv6 ne soit pas fonctionnelle …

Oui, j’ai un VPN FDN installé mais pas sur le serveur. Il est installé sur le routeur avec un fichier openvpn.

Mon routeur indique bien que je suis connecté à internet avec l’IPV6 du VPN FDN.

Il me semble que l’IPV6 du VPN FDN est bien fonctionnelle non ? Tu as une commande efficace pour checker sans que je me perde dans des inet0 je sais pas quoi :slight_smile: ?

Oui, c’est curl ip6.yunohost.org qu’on a fait avant et qui montre que l’ipv6 n’est pas active sur ton serveur

Perso je pencherais soit un soucis côté routeur qui ne t’attribue pas d’ipv6, soit ton serveur qui ne sais pas activer l’ipv6 automagiquement … Mais ça dépends beaucoup de ton routeur et/ou machine serveur (physique) et pas vraiment de yunohost … Tout ce que yunohost peut dire, c’est que l’ipv6 est pas fonctionnelle

Merci Aleks ,
Je penche pour mon serveur.
Bon je vais tripatouiller un peu …
Bonne fin d’après midi

Bon, c’était mon routeur que j’avais mal configué.

Maintenant l’output de curl ip6.yunohost.org est :
2001:910:13cc:0:48cf:c6e:91fa:d328#

Mais maintenant c’est les ports qui ne sont plus accessibles de l’extérieur en IPV6 ?

Tu peux checker sur https://ports.yunohost.org/ avec ton adresse IPv6.

Ok merci Kit.
Je tente d’ouvrir les ports pour l ipvV6 en checkant avec ton lien.