IPv6 Not Reachable

,

When I run the Diagnosis tool I’m getting issues under all of my ports along the lines of
" * Port 22 is not reachable from outside in IPv6"
as well as
“Domain direwolves.xyz appears unreachable through HTTP from outside the local network in IPv6, though it works in IPv4”
Under my Web tab.

These are the only issues I’m having.
DNS is configured correctly, and I can access my webserver remotely using my IP address.
I can’t however generate my cert, nor access my webserver remotely using my domain name.

For some context, I’ve ran Yunohost within VMPlayer on my windows 10 pc, and everything is fine, with no errors.
But now I’m trying to run it within ESXI Hypervisor and this is where I’m running into issues.
I’ve tried different network adapter configurations, and I can see an ipv6 address with “ip -a” as well as in my router list.
I don’t see a firewall option in my router config, or anything ipv6 related besides the addresses tied to my servers.

I’m using the Yunohost ISO file for the install, and I’ve also tried a debian install with manual install of yunohost to the same effect.

Hmpf, I don’t really know what to tell because configuring / debugging network is already hell when you’re in front of the terminal yourself, so that’s even harder when trying to help somebody remotely …

From what I understand from the messages you get from the diagnosis, Yunohost does see that you have an IPv6 and that you can reach external website in IPv6 (outgoing traffic), but apparently incoming traffic doesnt work for some reason. There could be a hundred explanation for this related to firewall / NAT / port forwarding not configured in IPv6 / … (both on the hypervisor-thingy and your home router).

I guess another “sad” alternative is to just disable IPv6 entirely on the system but that’s just depressing for the future of the internet

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.