ionCube needed for whmcs

My YunoHost server

Hardware: Rack amd 64
YunoHost version:
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I’m trying to install whmcs, but I need to install ionCube what’s the best way to do or is there a yunohost variant of ionCube?

@Aleks you must know this?

None of these two products seem to be open sourced free software so, no, they would not be available in YunoHost’s catalog.

As long as they do not interfere with core packages of YunoHost, i.e. trying to alter NGINX, firewall, necessary ports, you should be able to follow their installation instruction and integrate them in your YunoHost server with a Redirect app (if a service makes them available on port) or a Custom webapp (if you only have to unzip them and serve them through NGINX).

If you are paying for their licence fees, you should get support from them, maybe?

This was not the question

Thats more like it :wink: I just want to know what the best way is to combine or deploy it within my yuno server…

Sorry for misunderstanding you, I assumed it was the question:

I cannot guess the best way, I merely gave you the two options to integrate non-catalogged apps in YunoHost. It really depends on their installation process.

  • I cannot access the documentation for ionCube, not being a customer
  • whmcs seems to be installable by unzipping it, so a Custom webapp would maybe work.

That’s as far as I will help you. Good luck!

Well there are more worse things than a misunderstanding.

[quote=“tituspijean, post:5, topic:16105”]

  • I cannot access the documentation for ionCube, not being a customer.

So your second assumption, also a little hastily maybe? Not being a customer you can even get a trail version, also did you really miss the documentation link? But then what is this:

To me it seems like a plugin similar as GZIP and other php add-ons or am I now saying something stupid??

I BOUGHT the pack and used this How to Install ionCube Loader in Debian and Ubuntu then I succeeded :wink:

1 Like

Only one issue Remains… Can you help me on this one @tituspijean? Because SSO is now conflicting with the login of WHMCS I’ve set it to the visitors group and all users…

Let’s try to remove the headers injected by the SSO from these URLs:

app=YOUR_APP_ID  #should be my_webapp or my_webapp__2, etc.
source /usr/share/yunohost/helpers
ynh_permission_url --permission "main" --auth_header "false"


sorry where to put that? which file?

No, they are commands to be run in the CLI.

how stupid I see now

Uhm, what? But why?? what’s the way to change it in nano or something?

root@ecz-srv-01:~# source /usr/share/yunohost/helpers ynh_permission_url --permission "main" --auth_header "false"
-bash: XTRACE_ENABLE: readonly variable
-bash: MEDIA_GROUP: readonly variable
-bash: MEDIA_DIRECTORY: readonly variable
-bash: YNH_DEFAULT_PHP_VERSION: readonly variable
-bash: YNH_DEFAULT_COMPOSER_VERSION: readonly variable
basename: invalid option -- 'b'

These should be different commands.

app=YOU_APP_ID (to be changed as explained above)
source /usr/share/yunohost/helpers
ynh_permission_url --permission "main" --auth_header "false"

Last login: Mon Jun 14 20:12:22 2021 from
-bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
root@ecz-srv-01:~# app=my_webapp
root@ecz-srv-01:~# source /usr/share/yunohost/helpers
basename: invalid option -- 'b'
Try 'basename --help' for more information.
root@ecz-srv-01:~# ynh_permission_url --permission "main" --auth_header "false"
+ url=
+ add_url=
+ remove_url=
+ auth_header=false
+ clear_urls=
+ [[ -n '' ]]
+ [[ -n '' ]]
+ [[ -n '' ]]
+ [[ -n false ]]
+ '[' false == true ']'
+ auth_header=,auth_header=False
+ [[ -n '' ]]
+ yunohost tools shell -c 'from yunohost.permission import permission_url; permission_url('\''my_webapp.main'\''    ,auth_header=False )'

it just won’t…

Damn, I got this error recently, but I cannot remember what was the issue.

Anyway, let’s try to do what the helper is supposed to. In the CLI, again:

yunohost tools shell -c "from yunohost.permission import permission_url; permission_url('my_webapp.main' , auth_header=False)"


(edit: removal of extra comma, typing commands on phone is hard)

root@ecz-srv-01:~# yunohost tools shell -c "from yunohost.permission import permission_url
> permission_url('my_webapp.main' , ,auth_header=False)"
Traceback (most recent call last):
  File "/usr/bin/yunohost", line 72, in <module>
  File "/usr/lib/moulinette/yunohost/", line 25, in cli
    ret = moulinette.cli(args, output_as=output_as, timeout=timeout, top_parser=parser)
  File "/usr/lib/python3/dist-packages/moulinette/", line 120, in cli
    args, output_as=output_as, timeout=timeout
  File "/usr/lib/python3/dist-packages/moulinette/interfaces/", line 502, in run
    ret = self.actionsmap.process(args, timeout=timeout)
  File "/usr/lib/python3/dist-packages/moulinette/", line 600, in process
    return func(**arguments)
  File "/usr/lib/moulinette/yunohost/", line 738, in tools_shell
  File "<string>", line 2
    permission_url('my_webapp.main' , ,auth_header=False)
SyntaxError: invalid syntax

nope… :frowning:

Remove the extra comma.

no errors but still the redirect…

it is stil conflicting with sso @tituspijean any other methods maybe?