Invidious Update Failed

Huh, hi, got into a weird thing lately, i failed to update invidious, manually force it and then (concerning this post) failed to update it and (later not concerned by this post) failed to install it again.

My YunoHost server

Hardware: old laptop (thinkpad x220)
YunoHost version: (stable)
I have access to my server : Through SSH & direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no, usual updating once a week

Description of my issue

i tried it yesterday and the problem was crystal1.11 when i read the logs wasnt updated so i tried to --force updating it and it was already up to date. it returned An error occurred inside the app upgrade script and it just restored

So i left it until a new update of crystal (which is almost every week or so like unstable package??? :melting_face:) had a crystal update today i ran it before trying to update invidious, and succeed but the invidious update failed and returned Could not upgrade invidious: An error occurred inside the app upgrade script

i see crystal is faulty again but i cant understand why and this time it also failed to restore it, if y’all have some ideas about it Here the log. I saw here we could install crystal separately i also tried that but didnt helped me to pass this update nor reinstall invidious now.

I struggled with crystal yesterday

I had to completely uninstall it using apt remove crystal and apt autoremove

then I reinstalled it apt install crystal and now it’s fine


i dont have any crystal package installed and cant install the one named crystal returning error that it’s in conflict with crystal1.11 which isnt installed either.

so i tried to install crystal1.11 then trying to install invidious again, not much luck on that path either here the log for this attempt.


Doesn’t work for me either

sudo apt install crystal
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
crystal1.11 : Conflicts: crystal
E: Unable to correct problems, you have held broken packages.

Good thing there’s no ‘other problems’ than crystal

the issue is open in invidious-ynh repo.

1 Like

Somehow invidious got uninstalled for me and I can’t get it back cause of the crystal issue

Yeah until it get fixed on github, the package is broken.

I got the same:

  • got an update for invidious
  • unable to update (fails but it reverted back)
  • next day crystal update (passes without errors)
  • retry invidious update (fails, fails to backup)
  • impossible to install it again.

issue with crystal fixed. I was able to restore my backup and update just fine! Woot


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.