Internet Cube asks me to perform post install [Solution: Wait]

#1

Hello!

I am trying to install an internet cube (on a Lime2, with a .cube file for the VPN) following the steps provided at http://install.labriqueinter.net

Flashing the image goes well, as well as board startup. Still, when I connect to the web interface, it launches a yunohost update and then the postinstall phase: I have been told that this means that the additional elements of the internet cube have failed to install.
I tries a couple of times, same result.

How should I proceed to install an internet cube:

  1. Try again the same steps, or some other (I have been told that tools are somewhat unstable at the moment)?
  2. Should I go for yunohost and then add the right additional software to have a fully-fledged internet cube? What should I then install for this?

Thanks!

#2

Hi there,

so from install.labriqueinter.net, you should have obtained an hypercube file.

You need to provide this hypercube file to the setup either by :

  • using the appropriate argument in the install-sd.sh script when flashing the SD card (the script is available from here https://repo.internetcu.be/ (or similar page in french))
  • or plugging an USB key containing the file before your first boot the board

After that, you should find the local IP of your board (e.g. with arp-scan) and go to http://192.168.x.y:2468/install.html to find the installation debug page to follow the install process

Or another trick is to use this small page that uses black magic to do all this from your browser : https://repo.internetcu.be/tools/

The hypercube procedure is explained at the bottom of https://repo.internetcu.be/. Note that you should not perform the yunohost postinstall yourself. It is done by the hypercube install process among other things

Hope it helps !

#3

I heard that there’s an issue with the latest image available.
I just tried by myself here and I encountered the following errors during the first Debian upgrade.

Setting up yunohost-admin (3.5.2) ...
unable to write 'random state'
dpkg: error processing package yunohost-admin (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.84-sunxi
update-initramfs: Converting to u-boot format
Errors were encountered while processing:
 yunohost-admin
W: --force-yes is deprecated, use one of the options starting with --allow instead.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Please try the latest unofficial image named internetcube-stretch-3.4.2-lime2-stable.img.tar.xz. Download that file and when flashing the SD card you’ll have to use option “-f”, like this:

bash install-sd.sh -2y install.hypercube -f internetcube-stretch-3.4.2-lime2-stable.img.tar.xz
#4

@anne a new image has been uploaded yesterday, can you try again?

#5

Thanks @pitchum!

Still, after installing, connecting the lime to power and ethernet, on the web page I am prompted to start the postinstall. Seems like the issue is not resolved?

Edit
I didn’t notice at first that the new image was unofficial. Since the link you provided do not work, I tried with https://repo.labriqueinter.net/internetcube-stretch-latest-lime2.img.tar.xz and I still have the issue.

#6

Did you do that …?

1 Like
#7

@anne, same question as @Aleks: did you open http://192.168.x.y:2468/install.html after booting the cube for the first time?
It’s a web page showing the progress of the cube installation.
This is a very important step that lasts approximately 30 minutes and that must not be interrupted.

I guess it’s too late to view this page but if you can access your cube via SSH you may be able to read log files located in /var/log/hypercube/.

1 Like
#8

Forgot that, so I did it again and install process went right (apart from the known roundcube issue), clearly I wasn’t waiting enough and forgot to check the install webpage. So it seems that my issue wasn’t related to tools instability. Sorry and thank you so much!

1 Like
#9

The roundcube issue will be fixed in 2 days now: roundcube_ynh PR-64

#10

(At least in testing :sweat_smile:)