Internal Error when running Diagnosis


First post here for me. I’m fairly new to Yunohost but I really like it so far. I have run into a problem with the Diagnosis functionality that I can’t solve myself. If someone would be able to help out to restore it it would be great!

My YunoHost server

Hardware: Raspberry Pi 4 (4Gb version).
YunoHost version: 4.0.4 (stable)
I have access to my server : Through SSH and through the webadmin.
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain:
My Yunohost was out of diskspace.

Description of my issue

I had fairly recently made a clean installation of the Yunohost using a 32Gb SD-card. After the installation when I started to install apps I very unexpectedly ran out of diskspace (see below). At this point I ran a diagnosis of the system which worked fine.

  • To filter the diagnosis-list I started ignoring some false positives in the list that were unrelated to the matter (like non-open ports etc.).
  • Error messages appeared telling me that the “ignore”-operations failed due to out of diskspace.
  • At some point I triggered another diagnosis. Now the whole diagnosis operation failed with message “Yunohost encountered an internal error”, and keeps failing if I try again. Full logs are available here:

As a sidenote, the reason I was out of diskspace was that some systemd-job with a name that indicated that it resized the root-partition hadn’t run. After the diagnosis broke down I logged in through SSH, which triggered the job. Now I got my 32Gb back and can install applications (but Diagnosis is still broken though).

// Rasmus

Hmmmokay I think you can try to log in with SSH and run :

cat /etc/yunohost/diagnosis.yml

to display the content of the file … From what you report, I think it’ll be empty (and therefore the command won’t report anything)

In which case, just removing the file should fix the issue (it’ll automatically be recreated) :

rm /etc/yunohost/diagnosis.yml

That part is pretty weird o.O Did you trigger it manually ? Or maybe you rebooted the machine at some point …?

100% sure I did not trigger it manually but I think I had rebooted from web interface before this happened, yes.

How does the reboot explain this? Shouldn’t this job be a part of the installation?

Yes it should, but for some reason it didn’t run or failed … but rebooting the server possibly re-triggered the job …

I just went through the logs in /var/log/yunohost/… but can’t find anything suspicious. I’ll keep an eye out if something similar happens again. Thanks alot!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.