Installing Dolibarr corrupts (permissions in) Nextcloud external storage ?!

My YunoHost server

Hardware: : MacbookAir
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no - Some docker container installed but should not interfere

Description of my issue

Hi Again,
Following by issue with #nextcloud upgrade, I could not sync notes using #Joplin as I usually do. There was an error message saying some lock could not be removed.

Last error: Error: DELETE locks/1_1_0f5a643a6edb41548f543321abf6b864.json: (Exception Sabre\DAV\Exception\Forbidden) (403): <?xml version="1.0" encoding="utf-8"?> <d:error xmlns:d="DAV:" xmlns:s=""> <s:exception>Sabre\DAV\Exception\Forbidden</s:exception> <s:message/> </d:error>

I thought it was a nextcloud issue base on the error and initial googling. In fact, the lock table was empty and it was just the file itself that could not be removed, (yes, you should have better read the error message). I tried to delete the /media/Data/AppData/Joplin_notes/locks/1_1_0f5a643a6edb41548f543321abf6b864.json using the nextcloud web interface, I could not. :arrow_forward: it happened to be a permission issue again. And I have not fixed it yet as I am unsure how to handle it safely.

Right after I failed at upgrading nextcloud I have installed #dolibarr an ERP/CRM as I wanted to start some personal business. The app is ranked 7 so I thought it was safe to install. It turns out it was not.

On my nextcloud installation, I have an External hard drive connected for additional space which is mounted in /media/Data. This is where most of my files are located --including Joplin Notes

After Dolibarr’s installation, all the /media/Data ownership changed to Dolibarr:Dolibarr. Not sure whether permissions changed. This is why, the lock file cannot be removed, nextcloud does not have the permission anymore.

So few questions :

  1. Is it safe to chown nextcloud:nextcloud /media/Data -R *, or should it be another user ? maybe www-data ?
  2. How should I report it to the packaged team ?
  3. I assume Dolibarr expected to use a /media/Data directory to function, but by doing my chown command it might break ?

What are your thought on it and where is the best place to report that ?
I can switch to French :fr: if needed also :slight_smile:

Edit : I should mention that of course, I did the standart Dolibarr installation through the webadmin page and did not touch anything else

Any insight on that?

Well, I tried a # chown nextcloud:nextcloud * -R in my /media/Data folder and it seems to fix the issues, nextcloud seems to work fine and I can sync my joplin across diferent devices.

I hope there won’t be any side effect, but so far… so Good. I would still need to tell the dolibarr guys about that as I feel there might still be come conflict happening in the future…

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.