Installation WordPress impossible

#21

Though I think nslookup localhost will always do a real DNS request instead of checking /etc/hosts ? (It does a real request on my machine too)

#22

I didn’t choose this DNS, but I can change it (how todo )and remove 127.0.1.1 if you think it will help

#23

Je ne comprends pas trés bien

#24

It doesn’t on mine, which was a VM for the test.
Nor dig.

Actually, all my requests go to 127.0.0.1, probably because that’s my local dnsmasq which gets the request, as specified in its conf

listen-address=127.0.0.1

But indeed, I can see that my computer isn’t doing the same, it ask to my router for an answer, but gets 127.0.0.1 as well.

That’s quite worrying because those are google’s.

Aleks, do you have the same behavior on your ynh server ? dnsmasq should handle the requests.

#25

Bonjour,

Je me demandais quel était l’intérêt de tel ou tel DNS ; ne sont-ils pas, à quelques détails prés, tous équivalents pour le client lambda que je suis ? et surtout pour le fonctionnement d’une connection ?

#26

All DNS will provide approximately the same result, approximately because some, especially those from your ISP (Internet service provider), will filter some domain name considered as illegal.
But your DNS provider will know every website you’re going to, since you have to ask for each domain you’ll reach.
As you can imagine, google will not just forgot all domains you’re reaching, that’s google…

That’s why we provide a list of clean and respectful DNS, used by default by your dnsmasq.

#27

cela peut donc avoir un lien avec mmon problème d’installation de WP ? mais les autres applis se sont installées sans problème ; pourquoi WP ?
Tiens, je vais en essayer d’autres, pour voir…

#28

That’s not directly related no.
The problem here is that your dns resolution goes directly to a distant resolver, without asking to your local /etc/hosts. So you can’t resolve localhost

#29

Ah ok ; et donc, comment je peux remédier à ça ( mon niveau informatique ne m’autorise pas ce genre de manip sans crainte) ?

#30

The thing is, I don’t really know what’s going on…

Could you try something please?

Add this line to your /etc/hosts

127.0.0.1       yunohost.com

Then restart dnsmasq

sudo systemctl restart dnsmasq.service

And try to dig it

dig yunohost.com
#31

Ça a l’air de marcher :

#32

Ok, could you remove that line, and retry please ?

#33

Pareil !

#34

Really same result !?
Did you restart dnsmasq before ?

#35

Je viens de refaire un restart dnsmasq…etc… et j’ai bien le même résultat ; c’est pas normal ?

#36

Well… as dnsmasq is supposed to be your dns cache for this part, no after a restart you shouldn’t have the same result…

What about localhost now ?

#37

(j’aime bien cette conversation bilingue !)
dans /etc/hosts je n’ai plus de localhost ; probablement que je devrais en remettre un, non ? du genre

127.0.0.1 localhost

ou avec l’ip de sous-réseaux ? (192.168.0.16 )

#38

Yep, you should always have a 127.0.0.1 localhost into your /etc/hosts.

#39

Hop! la, Ok, c’est réparé.

#40

Do you mean that your resolution of localhost works now ?