Installation warning GoToSocial 0.9.0~ynh1

My YunoHost server

Hardware: VPS bought online /
YunoHost version: 11.1.20
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: GoToSocial 0.9.0~ynh1

Description of my issue

I installed the latest version of GoToSocial 0.9.0~ynh1 today.

Whilst installation was running the following warning came up:

Creating gotosocial admin user...
WARN: bun: 2023/05/25 22:13:00 query "remote_url" has [count(*)] args, but no placeholders

The app seems to have installed but would the above need to be addressed? I am not sure unfortunately, what this warning refers to.

Edit: I cant log into the app with the admin user, I repeatedly get an error:

401: Unauthorized: token not supplied

Not sure, probably it is related.

ping @OniriCorpe

Just uninstalled 0.9.0~ynh1 and installed the new version 0.9.0~ynh2, with the same warning.

That’s strange, 0.9.0 had a typo, upgrade should not have been a success : fix typo · YunoHost-Apps/gotosocial_ynh@13bfd33 · GitHub

I have two instances, I’ve updated both to v0.9-ynh2. (ynh1 failed yesterday)

First one no problem at all I could see ATM

Second, broken links to previously uploaded pictures/multimedia, avatar, custom emojis :person_shrugging: Links pointing to wrong file/folder.

I’ve reupload avatar/header and custom emojis but lost reference to old multimedia.

Both upgraded from YNH admin web interface.

1 Like

I just upgraded to 0.9.0~ynh2 and no errors. so I guess it’s something specific to your install?

I installed via command line.

yes, I think so, but it bugs me not knowing what I did to this instance and did not to the other.

Anyway, I’ve been looking in the cached content in mastodon instance and nobody will miss anything relevant (but myself).

So, I have tried to prune database to clean it and avoid conflicts or whatever but nothing was broken :thinking:

Orphaned media is defined as media that is in storage under a key that matches the format used by GoToSocial, but which does not have a corresponding database entry. This is useful for excising files that may be remaining from a previous installation, or files that were placed in storage mistakenly.

root@ynh:/var/www/gotosocial__2# ./gotosocial --config-path config.yaml admin media prune orphaned 
timestamp="26/05/2023 16:33:45.579" func=cache.(*Caches).Init level=INFO msg="init: 0x40003b4d00"
timestamp="26/05/2023 16:33:45.580" func=cache.(*Caches).Start level=INFO msg="start: 0x40003b4d00"
timestamp="26/05/2023 16:33:45.590" func=bundb.pgConn level=INFO msg="connected to POSTGRES database"
timestamp="26/05/2023 16:33:45.606" func=bundb.doMigration level=INFO msg="there are no new migrations to run"
timestamp="26/05/2023 16:33:46.010" func=prune.glob..func1 level=INFO msg="DRY RUN: 0 items are orphaned and eligible to be pruned"
timestamp="26/05/2023 16:33:46.010" func=bundb.(*basicDB).Stop level=INFO msg="closing db connection"
timestamp="26/05/2023 16:33:46.011" func=cache.(*Caches).Stop level=INFO msg="stop: 0x40003b4d00"

nothing to be pruned :person_shrugging:

timestamp=“26/05/2023 16:33:46.010” func=prune.glob…func1 level=INFO msg=“DRY RUN: 0 items are orphaned and eligible to be pruned”

I post this in case it is useful to anyone here, excuse me if I’m owning the thread

I tried the upgrade, no warning :thinking:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Does someone still experience this ? I can’t reproduce it.

1 Like