Installation synapse bloquee

,

Bonjour,

J’ai supprimé Jappix pour installer Synapse. Lors de l’installation de Synapase, je rencontre toujours le meme problème.
Le petit pacman reste bloqué. Je suis obligè de me déconnecter de l’interface administrateur.
Je souhaite utiliser RIOT par la suite.
Merci de votre aide.

Moi ca marche très bien depuis qqs mois. Synapse est a installer a la racine de ton domaine ou sous-domaine. ce qui veut dire que si tu a déjà des app sur ton domaine tu pourra pas installer synapse. Je suis en 2.7.9

Hello,

As tu bien essayé d’installer la version testing de synapse ?
Tu peux utiliser la commande suivante : sudo yunohost app install https://github.com/YunoHost-Apps/synapse_ynh/tree/testing --verbose

Merci, l’installation a bien fonctionné.

Bonjour,
je rencontre également un problème d’installation de Synapse. que j’essaie d’installer sur un sous-domaine.
Ci-joint les logs d’erreur.

https://paste.yunohost.org/raw/azevavuqod

Merci d’avance pour votre aide.

Hello,

@ericg peut tu vérifier que postgresql fonctionne par la commande systemctl status postgresql

Bonjour,

@Josue voici ce que renvoie la commande systemctl status postgresql

postgresql.service - PostgreSQL RDBMS
Loaded: loaded (/lib/systemd/system/postgresql.service; enabled; vendor preset: enabled)
Active: active (exited) since Mon 2018-07-16 22:49:52 CEST; 1 months 24 days ago
Main PID: 1309 (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 4915)
CGroup: /system.slice/postgresql.service

Et si tu essaye de te connecter à psql avec la commande sudo -u postgres psql ?

Ça me renvoie

could not change directory to "/root": Permission non accordée
psql: n'a pas pu se connecter au serveur : Aucun fichier ou dossier de ce type
Le serveur est-il actif localement et accepte-t-il les connexions sur la
socket Unix « /var/run/postgresql/.s.PGSQL.5432 »

Essaye de redémarrer postgresql avec la commande systemctl restart postgresql

This is happening with many apps using postgresql.
It this can be solved without uninstalling postgresql then nothing like this. But if nothing works you will have remove the postgresql and let the app reinstall it while fresh install.

Please take backup of any postgresql apps before doing this. Double check by installing pgadmin Maybe you can install pgadmin and see https://github.com/YunoHost-Apps/pgadmin_ynh and backing up all the databases.

Then do as describe in this comment https://github.com/YunoHost-Apps/peertube_ynh/issues/38#issuecomment-419140972

Hope this problem gets solved.

Merci @Josue @kanhu for your help,
unfortunately no result yet. I have removed postgresql, and installed Synapse after that.
I still get the same error… :thinking:

https://paste.yunohost.org/raw/cocodoruyo

Hello,

Sur quelle architecture est tu ?

Bonjour,
@Josue un VPS chez OVH

Et que te dis : netstat -ntlp | grep postgres

(Installer net-tools si pas encore installé)

Bonjour,
@Josue La commande netstat -ntlp | grep postgres ne renvoie rien…

que te donne cat /var/log/postgresql/postgresql-9.6-main.log ?

Bonjpur, @Josue
cat /var/log/postgresql/postgresql-9.6-main.log me renvoie :

2018-09-10 13:05:31.328 CEST [27348] LOG:  invalid value for parameter "lc_messages": "fr_BE.UTF-8"
2018-09-10 13:05:31.328 CEST [27348] LOG:  invalid value for parameter "lc_monetary": "fr_BE.UTF-8"
2018-09-10 13:05:31.328 CEST [27348] LOG:  invalid value for parameter "lc_numeric": "fr_BE.UTF-8"
2018-09-10 13:05:31.328 CEST [27348] LOG:  invalid value for parameter "lc_time": "fr_BE.UTF-8"
2018-09-10 13:05:31.328 CEST [27348] FATAL:  configuration file "/etc/postgresql/9.6/main/postgresql.conf" contains errors
2018-09-10 13:47:58.951 CEST [13675] LOG:  invalid value for parameter "lc_messages": "fr_BE.UTF-8"
2018-09-10 13:47:58.951 CEST [13675] LOG:  invalid value for parameter "lc_monetary": "fr_BE.UTF-8"
2018-09-10 13:47:58.951 CEST [13675] LOG:  invalid value for parameter "lc_numeric": "fr_BE.UTF-8"
2018-09-10 13:47:58.951 CEST [13675] LOG:  invalid value for parameter "lc_time": "fr_BE.UTF-8"
2018-09-10 13:47:58.951 CEST [13675] FATAL:  configuration file "/etc/postgresql/9.6/main/postgresql.conf" contains errors
2018-09-10 21:34:03.599 CEST [1297] LOG:  invalid value for parameter "lc_messages": "fr_BE.UTF-8"
2018-09-10 21:34:03.599 CEST [1297] LOG:  invalid value for parameter "lc_monetary": "fr_BE.UTF-8"
2018-09-10 21:34:03.599 CEST [1297] LOG:  invalid value for parameter "lc_numeric": "fr_BE.UTF-8"
2018-09-10 21:34:03.599 CEST [1297] LOG:  invalid value for parameter "lc_time": "fr_BE.UTF-8"
2018-09-10 21:34:03.599 CEST [1297] FATAL:  configuration file "/etc/postgresql/9.6/main/postgresql.conf" contains errors
2018-09-10 21:34:07.808 CEST [1316] LOG:  invalid value for parameter "lc_messages": "fr_BE.UTF-8"
2018-09-10 21:34:07.808 CEST [1316] LOG:  invalid value for parameter "lc_monetary": "fr_BE.UTF-8"
2018-09-10 21:34:07.808 CEST [1316] LOG:  invalid value for parameter "lc_numeric": "fr_BE.UTF-8"
2018-09-10 21:34:07.808 CEST [1316] LOG:  invalid value for parameter "lc_time": "fr_BE.UTF-8"
2018-09-10 21:34:07.808 CEST [1316] FATAL:  configuration file "/etc/postgresql/9.6/main/postgresql.conf" contains errors
2018-09-10 21:36:59.311 CEST [1547] LOG:  invalid value for parameter "lc_messages": "fr_BE.UTF-8"
2018-09-10 21:36:59.311 CEST [1547] LOG:  invalid value for parameter "lc_monetary": "fr_BE.UTF-8"
2018-09-10 21:36:59.311 CEST [1547] LOG:  invalid value for parameter "lc_numeric": "fr_BE.UTF-8"
2018-09-10 21:36:59.311 CEST [1547] LOG:  invalid value for parameter "lc_time": "fr_BE.UTF-8"
2018-09-10 21:36:59.311 CEST [1547] FATAL:  configuration file "/etc/postgresql/9.6/main/postgresql.conf" contains errors

As tu modifié le fichier /etc/postgresql/9.6/main/postgresql.conf. Si ce fichier contient une erreur c’est sûr que postgresql ne va pas redémarrer correctement. Il te faut regarder dans ce fichier ou est l’erreur.

Succès!
Comme les logs le montrent, le fichier postgresql.conf était configuré en fr_BE.UTF-8 :roll_eyes: comment… mystère.

Après

echo "LC_ALL=fr_FR.UTF-8" >> /etc/environment
echo "fr_FR.UTF-8 UTF-8" >> /etc/locale.gen
echo "LANG=fr_FR.UTF-8" > /etc/locale.conf
locale-gen fr_FR.UTF-8

j’ai désintallé Postgresql et installé Synapse, qui cette fois s’installe sans problème.

Merci encore pour votre aide!

1 Like